Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem with Connection between two Switches By Trunking Port - No pass Voice VLAN

Hi Cisco Gurus

I have a problem with the configuration of a Switch Cisco:

Switch#show flash

Directory of flash:/

    2  -rwx        2002   Mar 3 1993 02:14:20 +00:00  config.text
  584  -rwx           5   Mar 3 1993 02:14:20 +00:00  private-config.text
  585  -rwx        2072   Mar 3 1993 02:41:03 +00:00  multiple-fs
    3  drwx         512   Mar 1 1993 00:13:39 +00:00  c2960s-universalk9-mz.122-55.SE7

57931776 bytes total (42647552 bytes free)
Switch#show inventory
NAME: "1", DESCR: "WS-C2960S-24PS-L"

Switch#show runn
Switch#show running-config
Building configuration...

Current configuration : 2002 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c2960s-24ps-l
!
!         
spanning-tree mode pvst
spanning-tree extend system-id
!         
vlan internal allocation policy ascending
!         
!         
interface FastEthernet0
 no ip address
 shutdown
!         
interface GigabitEthernet1/0/1
 switchport mode trunk
!         
interface GigabitEthernet1/0/2
 switchport mode trunk
!         
interface GigabitEthernet1/0/3
 switchport mode trunk
!         
interface GigabitEthernet1/0/4
 switchport mode trunk
!         
interface GigabitEthernet1/0/5
 switchport mode trunk
!         
interface GigabitEthernet1/0/6
 switchport mode trunk
!         
interface GigabitEthernet1/0/7
 switchport mode trunk
!         
interface GigabitEthernet1/0/8
 switchport mode trunk
!         
interface GigabitEthernet1/0/9
 switchport mode trunk
!         
interface GigabitEthernet1/0/10
 switchport mode trunk
!         
interface GigabitEthernet1/0/11
 switchport mode trunk
!         
interface GigabitEthernet1/0/12
 switchport mode trunk
!         
interface GigabitEthernet1/0/13
 switchport mode trunk
!         
interface GigabitEthernet1/0/14
 switchport mode trunk
!         
interface GigabitEthernet1/0/15
 switchport mode trunk
!         
interface GigabitEthernet1/0/16
 switchport mode trunk
!         
interface GigabitEthernet1/0/17
 switchport mode trunk
!         
interface GigabitEthernet1/0/18
 switchport mode trunk
!         
interface GigabitEthernet1/0/19
 switchport mode trunk
!         
interface GigabitEthernet1/0/20
 switchport mode trunk
!         
interface GigabitEthernet1/0/21
 switchport mode trunk
!         
interface GigabitEthernet1/0/22
 switchport mode trunk
!         
interface GigabitEthernet1/0/23
 switchport mode trunk
!         
interface GigabitEthernet1/0/24
!         
interface GigabitEthernet1/0/25
!         
interface GigabitEthernet1/0/26
!         
interface GigabitEthernet1/0/27
!         
interface GigabitEthernet1/0/28
!         
interface Vlan1
 ip address dhcp
!         
ip http server
ip http secure-server
!         
line con 0
line vty 5 15
!         
end       
          
Switch#

I have another Switch that the configuration is the same:
 

Switch#show inventory                                                                       
NAME: "1", DESCR: "WS-C2960X-48FPS-L"                                                       

Switch#show flash                                                                           
Directory of flash:/                                                                        
                                                                                            
    2  -rwx        1916   Apr 3 2014 16:24:57 +00:00  private-config.text                   
    3  -rwx         676  Dec 26 2013 22:18:43 +00:00  vlan.dat                              
  647  -rwx        3850   Apr 3 2014 16:24:57 +00:00  config.text                           
    5  -rwx        3096   Apr 3 2014 16:24:57 +00:00  multiple-fs                           
    6  drwx         512  Jan 24 2001 07:53:04 +00:00  c2960x-universalk9-mz.150-2.EX3       
  645  drwx         512  Jan 24 2001 07:53:05 +00:00  dc_profile_dir                        
                                                                                            
122185728 bytes total (98723840 bytes free)                                                 
Switch#

Switch#show running-config
Building configuration...

Current configuration : 5144 bytes
!
! No configuration change since last restart
! NVRAM config last updated at 16:24:57 UTC Thu Apr 3 2014
!
version 15.0
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c2960x-48fps-l
!
!
!         
!         
crypto pki trustpoint TP-self-signed-1574858368
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1574858368
 revocation-check none
 rsakeypair TP-self-signed-1574858368
!
!
crypto pki certificate chain TP-self-signed-1574858368
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31353734 38353833 3638301E 170D3134 30343033 31363234
  35365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35373438
  35383336 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009F65 FBCAF74E 3D20BAB9 2D10653B B4A7DCF8 ADB23CD1 7F13FE33 FB751107
  F9C6A623 AEB2E682 CD860132 0D18FEB1 D88FCDEF 3D1EE280 52600EC0 D6CA6EB1
  D8760EED D5A81E70 69B3F95B 31027FC3 26D04C6F BAA7878B 796CD4AB 41AEC3F3
  E6CEDB00 3EEA703B 9C7DDFA3 DA8D6E84 403740DD 4A76417A A3DD62E3 E2FF73C0
  BC250203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1489CA98 8E749038 BC06383E 36B06AF8 6664FE97 95301D06
  03551D0E 04160414 89CA988E 749038BC 06383E36 B06AF866 64FE9795 300D0609
  2A864886 F70D0101 05050003 8181001F B6B73B9F 497C481E F42CD46E DDBC28C0
  9E6172AC 8CAC28FE E94F3268 62663C41 7DA60EE8 AAFA63AC 2DF6C6FC BE149FD6
  7027B042 7DCD29EB DFCE2655 F1A085CA 8DA477CA 36822DC2 7386C73D 9EEEB84C
  3E16F940 382BD067 641B5884 14FE583C D9AB44AD B593DA2C 256587D9 31F50410
  D74C9D09 DB54C92D 91558AE8 90B6D9
        quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 switchport mode trunk
!
interface GigabitEthernet1/0/7
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 switchport mode trunk
!
interface GigabitEthernet1/0/9
 switchport mode trunk
!
interface GigabitEthernet1/0/10
 switchport mode trunk
!
interface GigabitEthernet1/0/11
 switchport mode trunk
!
interface GigabitEthernet1/0/12
 switchport mode trunk
!
interface GigabitEthernet1/0/13
 switchport mode trunk
!
interface GigabitEthernet1/0/14
 switchport mode trunk
!
interface GigabitEthernet1/0/15
 switchport mode trunk
!         
interface GigabitEthernet1/0/16
 switchport mode trunk
!
interface GigabitEthernet1/0/17
 switchport mode trunk
!
interface GigabitEthernet1/0/18
 switchport mode trunk
!
interface GigabitEthernet1/0/19
 switchport mode trunk
!
interface GigabitEthernet1/0/20
 switchport mode trunk
!
interface GigabitEthernet1/0/21
 switchport mode trunk
!
interface GigabitEthernet1/0/22
 switchport mode trunk
!
interface GigabitEthernet1/0/23
 switchport mode trunk
!
interface GigabitEthernet1/0/24
 switchport mode trunk
!
interface GigabitEthernet1/0/25
 switchport mode trunk
!
interface GigabitEthernet1/0/26
 switchport mode trunk
!
interface GigabitEthernet1/0/27
 switchport mode trunk
!
interface GigabitEthernet1/0/28
 switchport mode trunk
!
interface GigabitEthernet1/0/29
 switchport mode trunk
!
interface GigabitEthernet1/0/30
 switchport mode trunk
!
interface GigabitEthernet1/0/31
 switchport mode trunk
!
interface GigabitEthernet1/0/32
 switchport mode trunk
!
interface GigabitEthernet1/0/33
 switchport mode trunk
!
interface GigabitEthernet1/0/34
 switchport mode trunk
!
interface GigabitEthernet1/0/35
 switchport mode trunk
!
interface GigabitEthernet1/0/36
 switchport mode trunk
!
interface GigabitEthernet1/0/37
 switchport mode trunk
!
interface GigabitEthernet1/0/38
 switchport mode trunk
!         
interface GigabitEthernet1/0/39
 switchport mode trunk
!
interface GigabitEthernet1/0/40
 switchport mode trunk
!
interface GigabitEthernet1/0/41
 switchport mode trunk
!
interface GigabitEthernet1/0/42
 switchport mode trunk
!
interface GigabitEthernet1/0/43
 switchport mode trunk
!
interface GigabitEthernet1/0/44
 switchport mode trunk
!
interface GigabitEthernet1/0/45
 switchport mode trunk
!
interface GigabitEthernet1/0/46
 switchport mode trunk
!
interface GigabitEthernet1/0/47
 switchport mode trunk
!
interface GigabitEthernet1/0/48
 switchport mode trunk
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 no ip address
!
ip http server
ip http secure-server
!
!
!         
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch#

The Problem is when I connect my IP Phone Alcatel in the First Switch (24 port), These IP phone Can not register, like the Voice VLAN is passing for this Switch.

If I do the same procedure  by using the seconf Switch (48 port), Mi IP Phone function correctly, they are register with my IP PBX.

What will be the problem, if the configuration is the same in both Switch, What do you meant. IOS will be the problem?

 

I hope your suggestion /recommendation

 

Best Regards

Andres

 

 

 

 

 

3 REPLIES
VIP Super Bronze

Hi,Is the first switch POE

Hi,

Is the first switch POE?

Can you post "sh ver" from both switches?

HTH

New Member

need more info.  How are the

need more info.  How are the switches connected?  Are they directly connected to each other or are they both connected to an upstream switch?  Where is the PBX plugged in at on the network?  Also, I rarely see voip ports configured as trunk ports anymore.  The standard practice now is the following:

int g0/0

swithcport voice vlan 1

switchport mode access

switchport access vlan 2 (This would be the data vlan for the PC's behind the phone)

New Member

Hi GuruAfter upgrade this

Hi Guru

After upgrade this switch (24 ports) from "c2960s-universalk9-mz.122-55.SE7" to "c2960s-universalk9-tar.152-1.E2.tar", My IP Phone function correctly.

 This is the first case that I observe this event.

 

Best Regards

Andres

179
Views
0
Helpful
3
Replies
CreatePlease to create content