Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problem with default router via Static DHCP

Hi all!

Here is a problem with static DHCP. I have 2 DHCP pools on a router for 2 ethernet subinterfaces:

ip dhcp pool First_Insurance

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

ip dhcp pool Netassets

network 192.168.4.0 255.255.255.0

default-router 192.168.4.1

interface FastEthernet0/1.2

description First_Insurance

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

ip access-group First_Insurance_in in

ip nat inside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.4

description Netassets

encapsulation dot1Q 4

ip address 192.168.4.1 255.255.255.0

ip access-group Netassets_in in

ip nat inside

ip virtual-reassembly

no cdp enable

!

Also there is DHCP pool for binding IP to MAC:

ip dhcp pool Static

origin file tftp://xxx.xxx.xxx.xxx/dhcp/static.txt

TFTP server contains a file with MAC-IP mapping, for example:

192.168.4.2 /24 id 0100.0d61.4520.e3 Infinite

But when a workstation with MAC 000d.6145.20e3 try to obtain information via DHCP it receive address 192.168.4.2 and default router 192.168.2.1!

Where is a problem??

4 REPLIES

Re: Problem with default router via Static DHCP

can you juz release release & renew the ip address on the workstation, also try clearing the dhcp binding database.

in workstation

--------------

ipconfig /release

ipconfig /renew

in router

---------

router#clear ip dhcp binding *

where * meanz clear all bounded ip addresses.

also i could never see any gateway information in the tftp server mapped file i.e static.txt

New Member

Re: Problem with default router via Static DHCP

Ofcourse, i've try to release and renew on workstation - no effect. Same effect from clear ip dhcp binding * and from no service dhcp - ser vice dhcp. Debug DHCP shows this:

Apr 17 10:48:57.952: DHCPD: Sending notification of DISCOVER:

Apr 17 10:48:57.952: DHCPD: htype 1 chaddr 0013.4622.1eda

Apr 17 10:48:57.952: DHCPD: remote id 020a0000c0a8050101000005

Apr 17 10:48:57.952: DHCPD: circuit id 00000000

Apr 17 10:48:57.952: DHCPD: Seeing if there is an internally specified pool class:

Apr 17 10:48:57.952: DHCPD: htype 1 chaddr 0013.4622.1eda

Apr 17 10:48:57.952: DHCPD: remote id 020a0000c0a8050101000005

Apr 17 10:48:57.952: DHCPD: circuit id 00000000

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.2 / 255.255.255.0 (Static)

Apr 17 10:48:57.952: DHCPD: parent pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: pool First_Insurance has no parent.

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.2 / 255.255.255.0 (Static)

Apr 17 10:48:57.952: DHCPD: parent pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: pool First_Insurance has no parent.

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.2 / 255.255.255.0 (Static)

Apr 17 10:48:57.952: DHCPD: parent pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: child pool: 192.168.2.0 / 255.255.255.0 (First_Insurance)

Apr 17 10:48:57.952: DHCPD: pool First_Insurance has no parent.

Apr 17 10:48:57.956: DHCPD: Sending notification of ASSIGNMENT:

Apr 17 10:48:57.956: DHCPD: address 192.168.5.7 mask 255.255.255.0

Apr 17 10:48:57.956: DHCPD: htype 1 chaddr 0013.4622.1eda

Apr 17 10:48:57.956: DHCPD: lease time remaining (secs) = 4294967295

Hall of Fame Super Gold

Re: Problem with default router via Static DHCP

Dmitry

Does the static pool have any definition of default router?

On which interface is the request from the PC with the matching MAC address arrive?

HTH

Rick

New Member

Re: Problem with default router via Static DHCP

Static pool have no any definitions of default router, request arriving on interface fa0/1.5 with address 192.168.5.1

288
Views
0
Helpful
4
Replies
CreatePlease to create content