Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Problem with Etherchannel and NIC Teaming

I am trying to Etherchannel two ports where the NIC's are teamed and the ports will not come up...what am I doing wrong?

I configured the two ports as follows

channel-group 195 mode active

port-channel load-balance src-mac

and I set the teamed NIC as follows

Team Type: 802.3ad Dynamic with Fault Tolerance

Transmit Load Balancing Method: Destination IP Address

The port now shows disabled when I do show int status and when I show config it shows shutdown. I ran the no shut on both ports but nothing changed.

here are the show int outputs and the show etherchannel

interface GigabitEthernet9/35

switchport

switchport access vlan 3

switchport mode access

no ip address

shutdown

spanning-tree portfast

channel-group 195 mode active

interface GigabitEthernet10/35

switchport

switchport access vlan 3

switchport mode access

no ip address

shutdown

spanning-tree portfast

channel-group 195 mode active

6513#show etherchannel 195 sum

Flags: D - down P - bundled in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

M - not in use, minimum links not met

u - unsuitable for bundling

w - waiting to be aggregated

Number of channel-groups in use: 4

Number of aggregators: 4

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

195 Po195(SD) LACP Gi9/35(D) Gi10/35(D)

Thanks,

Burleyman

5 REPLIES
New Member

Re: Problem with Etherchannel and NIC Teaming

Here is a helpful link. I think you might want to no shut your ports before connecting the server and configuring the etherchannel. You have selected channel mode active, but may want to try mode on.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

New Member

Re: Problem with Etherchannel and NIC Teaming

Try to enable the ports. They are shutdown

New Member

Re: Problem with Etherchannel and NIC Teaming

Burleyman,

Can you post the configuration of "interface port-channel 195" ?

Sander

Re: Problem with Etherchannel and NIC Teaming

From past experience especially with HP NIC teaming for fault-tolerance I specifically configure the etherchannel to mode on.

Incidentally I have come across issues with etherchannels failing to establish when you have subsequently reconfigured the actual port-channel after configuring it logically on the physical interface. For example add vlans if L2.

In these cases I initiated a 'shut' then a 'no shut' on the port-channel. Verify that PO195 is a switchport, and the appropriate vlan has been specified.

Regards

Allan.

Pls rate this post if you find it helpful.

New Member

Re: Problem with Etherchannel and NIC Teaming

Etherchannel "mode on" is only valid with HP NIC Teaming modes "Switch-assisted Load Balancing (SLB)" and "Dual Channel".

Any HP NIC Teaming type with "802.3ad" in it's title uses 802.3ad LACP to establish the channel. Therefore, the switch must be configured to also use LACP (mode active or mode passive).

In summary, "etherchannel mode active" is the correct config for "Team Type: 802.3ad Dynamic with Fault Tolerance".

The 80+ page HP Teaming whitepaper below provides all the details.

ftp.compaq.com/pub/products/servers/networking/TeamingWP.pdf

Based on the provided config, I agree that the problem is related to the interfaces being shut.

Regards,

-sean

___________________

sean@hp.com

CCIE #18040

HP ProLiant Engineering

3973
Views
6
Helpful
5
Replies