Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem with routing catalyst 3750

howto_3550_intervlanrouting.gif

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Vlan2
Switch(config-if)#ip address 10.1.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 200.1.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2

The ip 20.1.1.2 is not pingabile.

How can I ping 20.1.1.2 and a possible DNS server with ip 20.1.1.10?

  • LAN Switching and Routing
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Problem with routing catalyst 3750

Hello Claudio,


From the results it seems that the 10.10.10.1 machine doesn't know about 192.168.0.x network or else the default gateway set on the same is not correct.


Can you please confirm that as also suggested by Jon.


Regards

/Akhil

43 REPLIES
New Member

Re: Problem with routing catalyst 3750

The ip 20.1.1.2 is not pingabile.

How can I ping 20.1.1.2 and a possible DNS server with ip 20.1.1.10?

That IP address is not part of any of the above networks?  That would be handled by your default route.

I tried pinging that address and I get no response.

Did you mean that 200.1.1.2 is not pingable?

Hall of Fame Super Gold

Re: Problem with routing catalyst 3750

Is "ip routing" enabled?

Hall of Fame Super Blue

Re: Problem with routing catalyst 3750

In addition to Leo's suggestion does the default router in your diagrma have routes back to the vlans on your 3750 switch. If not you either need to run a routing protocol between the 3750 and the default router or add static routes to the default router eg.

ip route 10.1.2.0 255.255.255.0 200.1.1.1

etc. for each vlan

in addition how is your default router exchanhing routes with the corporate network ??

Jon

Purple

Re: Problem with routing catalyst 3750

  Jon beat me to it  but he is correct unless you have  statics pointing back to your 3550 the net router has no idea what to do with those packets because you are not running a dynamic routing protocol.

New Member

Re: Problem with routing catalyst 3750

I can ping the 20.1.1.1 can not ping the rest of the network 20.1.1.x.
I can also surf the internet.
I need access to DNS servers on the network 20.1.1.x.

New Member

Re: Problem with routing catalyst 3750

Sorry I made a mistake, that's the right image

Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 20.1.1.1 255.255.255.0
Switch(config-if)#no shutdown

I need to see the network 20.1.1.x

New Member

Re: Problem with routing catalyst 3750

Do a show ip route on the 3550 and the default router.

Make sure that the default router has routes to the 10.1.2.0, 10.1.3.0 and 10.1.10.0 networks.

Try pinging from the default router to hosts on those networks?

Are there any ACL's that could be blocking?

New Member

Re: Problem with routing catalyst 3750

Sorry, I did a bit of confusion.
Here is the scheme of my network with the configuration of 3750.

Building configuration...

Current configuration : 1419 bytes
!
version 12.2
service config
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750-24ts
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet1/0/1
!
.
.
.
.
!
interface FastEthernet1/0/24
no switchport
ip address 10.10.10.80 255.255.255.0
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.138
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

Switch#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.10.10.138 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet1/0/24
C    192.168.0.0/24 is directly connected, Vlan1
S*   0.0.0.0/0 [1/0] via 10.10.10.138

I did not create or modify ACL

So I can ping the 192.168.0.1, 10.10.10.80 and I can go on the Internet.

I can not ping the 10.10.10.138, 10.10.10.1, and the network 10.10.10.x

Thanks for your help and sorry for the confusion

Hall of Fame Super Blue

Re: Problem with routing catalyst 3750

So I can ping the 192.168.0.1, 10.10.10.80 and I can go on the Internet.

I can not ping the 10.10.10.138, 10.10.10.1, and the network 10.10.10.x

Thanks for your help and sorry for the confusion

Ping it from where ie. a client in the 192.168.1.x network/the switch or the router ???

The unmanaged switch - what device is it ie. make and model ??

Jon

2212
Views
0
Helpful
43
Replies