Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problems Connecting a 3825 Router to a 3508 Switch

Hi,

I have a 3825 that I am trying to connect to a 3508 Switch via 1000BASE-SX.  I have an SFP in Gi0/0 of the router and a 1000BASE-SX model in Gi0/8 of the switch.  Both the switch and the router can see each other when using the "show cdp neighbors" command.  As a side note, I also have a NMD-36-ESW (36 port switch) in the router which is functioning normally. When connecting to that 36 port switch, I get an IP and traffic flows normally. 

I've tried creating a subinterface on the 3825 and enabling a dotq encapsulation, but I do not get any connectivity.  I cannot ping the router from the switch, or vice versa.

I've included my running configs below.  Any help would be greatly appreciated.

Thanks!

===================================
3825 Router Configuration
===================================

Current configuration : 3396 bytes
!
! Last configuration change at 04:20:35 UTC Fri Aug 23 2013
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname <removed>
!
boot-start-marker
boot-end-marker
!
!
card type t3 1
enable secret 5 <removed>
enable password <removed>
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
ip cef
!
!
ip dhcp excluded-address 10.0.0.1 10.191.255.255
!
ip dhcp pool main-pool
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 192.1.1.1 8.8.8.8
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
!
!
redundancy
!
!
controller T3 1/0
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
mtu 1492
no ip address
duplex auto
speed auto
media-type sfp
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
!
interface GigabitEthernet0/1
mtu 1492
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
media-type rj45
no mop enabled
!
interface Serial1/0
no ip address
dsu bandwidth 44210
!
interface FastEthernet2/0
no ip address
...(Removed for brevity)
!
interface FastEthernet2/35
no ip address
!
interface Vlan1
ip address 10.0.0.1 255.0.0.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 1 permit any
!
!
!
!
snmp-server community <removed> RO
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password <removed>
login local
transport input ssh
!
scheduler allocate 20000 1000
end


===============================================
3508 Switch Configuration
===============================================
Current configuration:
!
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3508-1
!
enable secret 5 <removed>
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface VLAN1
ip address 10.0.0.2 255.0.0.0
ip directed-broadcast
no ip route-cache
!
ip default-gateway 10.0.0.1
snmp-server engineID local 0000000902000009E8E1C480
snmp-server community <removed> RW
snmp-server community <removed> RO
!
line con 0
exec-timeout 0 0
transport input none
stopbits 1
line vty 0 4
password <removed>
login local
line vty 5 15
password <removed>
login
!
end

2 REPLIES

Re:Problems Connecting a 3825 Router to a 3508 Switch

Ge0/0 is not a switchport but a routed port, therefore it won't bridge to the vlan1 SVI. You have to assign an IP address to gi0/0.1 interface.


Sent from Cisco Technical Support Android App

New Member

Re:Problems Connecting a 3825 Router to a 3508 Switch

Hi,

Thanks for the response, but I think I'm missing something.  If I tried to give the subinterface on the router an address of 10.0.0.3, I get an error that IP address overlaps with Vlan1.  If I assign the subinterface an address of 20.0.0.1 and assign the Vlan1 switch to 20.0.0.2 they can ping each other.  However, in this case, a PC on the switch can't ping anything outside.

Thanks

438
Views
0
Helpful
2
Replies