Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Problems vlan remapping

Problems in interface vlan remapping

I have 2 Nexus 5010 in HA, managing 5 Sw 2148.

I require to change interfaces that are in VLAN 10 to VLAN 280,

but when I switch vlan i lose connectivity between servers.

even change the server address to a new segment to the vlan 280. but nothing.

What do I need? or should I reconfigure?

------------------------------------------------

# SHow RUnning-config

version 4.1(3)N2(1a)
no feature telnet
no telnet server enable
feature tacacs+
cfs eth distribute
feature udld
feature interface-vlan
feature lacp
feature vpc
vpc domain 10
  role priority 1
  peer-keepalive destination 2.2.2.2
feature fex

role name default-role
  description This is a system defined role and applies to all users.
username admin password 5 $1$fY90Voca$9/fvGrZC/yLYHP5mHtwkD/  role network-admin
username nextira password 5 $1$gYtiwF.T$AQV2mtuWr/LuVmbWim.JH/  role network-adm
in
no password strength-check
ip domain-lookup
ip domain-name tlcomm.com

ip host NEXUS_A 2.2.2.1
aaa group server tacacs+ tacacs
hostname NEXUS_A
class-map type qos jumbomtu
policy-map type qos jumbomtu
policy-map type network-qos jumbo
policy-map type network-qos jumbomtu
  class type network-qos class-default
    mtu 9216
system qos
  service-policy type network-qos jumbomtu
fex 110
  pinning max-links 1
  description NEXUS2K_110
  type "Nexus 2148T"
fex 111
  pinning max-links 1
  description NEXUS2K_111
  type "Nexus 2148T"
fex 112
  pinning max-links 1
  description NEXUS2K_112

  type "Nexus 2148T"
fex 113
  pinning max-links 1
  description NEXUS2K_113
  type "Nexus 2148T"
fex 114
  pinning max-links 1
  description NEXUS2K_114
  type "Nexus 2148T"
fex 115
  pinning max-links 1
  description NEXUS2K_115
  type "Nexus 2148T"
snmp-server user admin network-admin auth md5 0xda56df7a586c74ce2638690f561fccd2
priv 0xda56df7a586c74ce2638690f561fccd2 localizedkey
snmp-server user nextira network-admin auth md5 0x8785744f5044febb932a618ec301be
36 priv 0x8785744f5044febb932a618ec301be36 localizedkey
snmp-server host 10.0.10.19 traps version 2c public  udp-port 1163
snmp-server host 10.0.10.19 traps version 2c public  udp-port 1165

vrf context management
vlan 1,10

vlan 130
  name Produccion
vlan 140
  name Administracion
vlan 280
  name DELL_6248
vlan 290
  name REDRESPADO
vlan 315
  name Almacenamiento
vlan 325
  name Admin_Virtual_I
spanning-tree vlan 280 priority 24576


interface Vlan1

interface Vlan10
  no shutdown
  ip address 20.0.10.251/16

interface Vlan140

  ip address 172.20.20.25/24

interface Vlan290
  no shutdown
  description REDRESPALDO
  ip address 20.1.13.251/16

interface port-channel1
  description VPC_NEXUS_B
  switchport mode trunk
  vpc peer-link
  spanning-tree port type network
  speed 10000

interface port-channel2
  description PORTCHANNEL_VSS_6509
  switchport mode trunk
  switchport trunk allowed vlan 130,140
  vpc 2
  speed 10000

interface port-channel110

  description NEXUS2K_110
  switchport mode fex-fabric
  vpc 110
  fex associate 110
  service-policy type qos input jumbomtu

interface port-channel111
  description NEXUS2K_111
  switchport mode fex-fabric
  vpc 111
  fex associate 111

interface port-channel112
  description NEXUS2K_112
  switchport mode fex-fabric
  vpc 112
  fex associate 112

interface port-channel113
  description NEXUS2K_113
  switchport mode fex-fabric
  vpc 113

  fex associate 113
  service-policy type qos input jumbomtu

interface port-channel114
  description NEXUS2K_114
  switchport mode fex-fabric
  vpc 114
  fex associate 114

interface port-channel115
  description NEXUS2K_115
  switchport mode fex-fabric
  vpc 115
  fex associate 115

interface Ethernet1/1
  description NEXUS2K_110
  switchport mode fex-fabric
  fex associate 110
  channel-group 110

interface Ethernet1/2

  description NEXUS2K_111
  switchport mode fex-fabric
  fex associate 111
  channel-group 111

interface Ethernet1/3
  description NEXUS2K_112
  switchport mode fex-fabric
  fex associate 112
  channel-group 112

interface Ethernet1/4
  description NEXUS2K_113
  switchport mode fex-fabric
  fex associate 113
  channel-group 113

interface Ethernet1/5
  description NEXUS2K_114
  switchport mode fex-fabric
  fex associate 114
  channel-group 114

interface Ethernet1/6
  description NEXUS2K_115
  switchport mode fex-fabric
  fex associate 115
  channel-group 115

.......

interface Ethernet110/1/13

  description MEDIA_SERVER_1_M1

  switchport access vlan 10

  service-policy type qos input jumbomtu

interface Ethernet110/1/25
  description MEDIA_SERVER_2_M1

  switchport access vlan 10
  service-policy type qos input jumbomtu

......

any thoughts?

Thanks

Everyone's tags (2)
3 REPLIES
VIP Super Bronze

Problems vlan remapping

Hi,

Did you make the new vlan active?

switch(config-vlan)#                      state {active |                      suspend}

HTH

Bronze

Problems vlan remapping

I'm not sure if I understand the full picture of what you're trying to do.

I note in your config that on this N5K, you have an SVI configured for VLAN 10 but not for VLAN 280.  Where is the routing occuring for the subnets in these VLANs?

Also I note that you are trunking two VLAN's towards a VSS pair, but not VLAN 10 or 280.  Again, not really sure where your L3 boundary is supposed to be.

Please explain your L3 topology a bit further and that may help shed light on where your issue is.

If your L3 config/routing is all set up properly somewhere upstream (and the trunk is omitted from this config) -- then theoretically you should be able to change the IP Address of the server from the old subnet on VLAN10 to the new one on VLAN280 (at this point you lose connectivity to server), then change the access VLAN, and the server should be reachable on new IP.  If this is the process you're trying to do, keep in mind you will take a service outage per server, as you need to coordinate the IP address change and the VLAN change.  Also, keep in mind an SVI will stay down until there is an active port or trunk with it configured.  You may need to wait a few seconds for the SVI to come up as well.

Hope this provides some help -- and I hope I will be able to give more concise answers once I better understand your L2/L3 topology.

Matt

Problems vlan remapping

Hi, mgalazka ,Reza Sharifi,  thanks for your help.

I have 125 servers in a backup independent LAN for NBU, with this segment 20.0.x.x/16. VLAN 10

This servers are organized in 6 cisco switches 2148. this switches are managed by two nx 5010 in HA, so, the confoguration in Nexus A an B for the interfaces for the 6 sw's 2148 should be the same.

The instruction is to switch all the servers from VLAN 10 to VLAN 280 without changing the ip addresses of the servers.

The VLAN 280 are active.

For testing, I take 2 servers to reassign from VLAN  10 to VLAN 280. but when i do that a lost conectivity on the servers.

I change the VLAN of the servers, deactvate and reactivate the NICs on the servers, but nothig.

Even i do the same test on VLAN 290, change the segmen to 20.1.x.x/16,

In short, I made many tests and came to the conclusion that something is missing from the configuration of the Nexus 5k for VLAN 280.

According to me, I just need to create the VLAN, make it active, and reassign the interfases of the sw 2148 on both sw 5010. but does not work and I do not know what may be the cause.

Cesar

1026
Views
0
Helpful
3
Replies
CreatePlease to create content