Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problems with etherswitch HWIC on 1841

I have a Cisco 1841 router with an ADSL card (WIC-1ADSL-DG) and I recently added an etherswitch card (HWIC-4ESW). The problem that I'm having is that any device connected to the etherswitch card can't see my network. I want to find a way to connect the etherswitch card to my router's network without setting up a truncking port and then connecting a crossover cable from the etherswitch card to the second built-in ethernet interface on the router.

5 REPLIES

Re: Problems with etherswitch HWIC on 1841

u should creat a vlan and vlan interface for ur etherswitch

as follow

vlan database

vlan 10 name data_vlan

then make and SVI interface

interface vlan 10

ip address 10.1.1.1 255.255.255.0

no shut

this should be ur internal network

then

interface range FastEthernet0/1-16

switchport mode access

switchport access vlan 10

no shut

spanning-tree portfast

Ethernet switch module can function as a Layer 2 switch connected to a Layer 3 router

then should work

and the following link will guid you in more details

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a00808066b8.shtml

good luck

please if helpful Rate

New Member

Re: Problems with etherswitch HWIC on 1841

It dosn't seem to be working. For one thing, when I assign my vlan an ip address that's in the same range as my router, I get the error: "192.168.0.0 overlaps with FastEthernet0/0" If I assign vlan 1 an ip address in a different range, any computer attached to it can't go out to the internet because the default gateway is on a different network.

Re: Problems with etherswitch HWIC on 1841

when u assign vlan 1 ip address for example

interface vlan 1

ip address 10.1.1.1 255.255.255.0

no shut

ur users must be on the 10.1.1.0/24 subnet

and thier default gateway must be vlan 1

which is 10.1.1.1

i mean the users connected to the etherswitch and are on vlan one

good luck

rate if helpful

New Member

Re: Problems with etherswitch HWIC on 1841

I know, but it still does't work.

Re: Problems with etherswitch HWIC on 1841

can u do

show run

and

show ip route

and post them here

332
Views
0
Helpful
5
Replies