Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Problems with OSPF adjacency

Hello all,

We are having problems with ospf adjacency on a cisco 1900 router. The problem is the following:

We have mora than 70 lines conected to a central router and only one is having adjancecy problems. At firts we thougth it was because of the mtu size, because it was different o both sides, but we use the "ip mtu ignore" command and the problem is still there. As a second idea, we thougth it was an authentication problem, because the output of the "debug ip ospf events" was the following:

Oct  7 12:13:37: OSPF: Rcv pkt from IP,interface : Mismatch Authentication type. Input packet specified type 2, we use type 0
Oct  7 12:13:43: OSPF: Send hello to IP area nº on interface from IP

So, we authorize MD5 authentication on both sides and with the same passwords, but doesn´t work either. The configuration is the same in all the routers and this is the only one which does not established adjacency it keeps at LOADING state.

We would like to know what is happening with this so we would be grateful if anyone could help us.

Thank you all.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Problems with OSPF adjacency

Ok , I thought it was not resolved. thanx.

One Question : you had told earlier , you had recieved authentication mismatch , if it was line problem why did u say authentication mismatch ?

Regards,

M.I.

8 REPLIES

Re: Problems with OSPF adjacency

Hi,

In addition to "ip mtu ignore " can you please issue "ip mtu 1500" on both end and also match network type.

like if it is ethernet circuit and used as a p2p link then please issue ip ospf network point-to-point command at both end

Moreover if you can share your ospf and interface config which will be more helpful

Regards

Mahesh

Community Member

Re: Problems with OSPF adjacency

Hi Mahesh,

We are gpoing to try to do what you are saying.

Tha ospf configuration is the following:

sh run int tu1116

Building configuration...

Current configuration : 323 bytes

!

interface X

description Central Router  2Mbps(E)

bandwidth 2000

ip address IP wildcard

ip mtu 1400

ip ospf message-digest-key 5 md5 7 password

ip ospf network point-to-point

ip ospf mtu-ignore

cdp enable

tunnel source Y

tunnel destination IP

router ospf 1

router-id IP

log-adjacency-changes

auto-cost reference-bandwidth 1000

area area_number authentication message-digest

passive-interface Vlan

passive-interface Vlan

networkIP wildcard area area_number

network IP wildcard area area_number

Please let me know if you have some other ideas ok?

Thank you.

Community Member

Re: Problems with OSPF adjacency

Ok , As it is a tunnel interface , no need to configure mtu , point-point network type ( by default it is point-point interface only) , and ip ospf mtu-ignore.

Please remove these command (on both side) , and see the result.  if it's not working again, do  debug ip ospf adj and share the details

Also, makesure the ping reachability as well.

Regards,

M.I.

Community Member

Re: Problems with OSPF adjacency

Hi,

Which type of interface you are using ( Is it ethernet or serial) ?

Are you able to ping both routers interface ip successfully ?

Please provide the below details.

1.show ip ospf interface xx  on both the routers 

2.provide the output of sh run interface xx  on both routers , to verify the autherntication config on both routers.

NOTE : here xx meant the interface of the router which are going to build neighbour relation with other router.

I hope , the above deatils will be solving your problem.

Regards,

M.I.

Community Member

Re: Problems with OSPF adjacency

Hello M.I,

Here you have the outputs you asked for:

Remote: sh ip ospf int xx
int xx is up, line protocol is up
  Internet Address IP, Area area_number
  Process ID id_number, Router ID IP, Network Type POINT_TO_POINT, Cost: 500
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           500       no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 4/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 5

Central: sh ip ospf int xx
int xx is up, line protocol is up
  Internet Address IP, Area area_number
  Process ID id_number, Router ID IP, Network Type POINT_TO_POINT, Cost: 500
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 145/147, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 49
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
     Youngest key id is 5

Central:

interface xx

description remote_name Gi  2Mbps(E)

bandwidth 2000

ip address IP wildcard

ip mtu 1400

ip ospf message-digest-key 5 md5 7 password

ip ospf network point-to-point

ip ospf mtu-ignore

cdp enable

tunnel source int Vlan

tunnel destination IP

end


Remote:

interface xx

description central_name 2Mbps(E)

bandwidth 2000

ip address IP wildcard

ip mtu 1400

ip ospf message-digest-key 5 md5 7 password

ip ospf network point-to-point

ip ospf mtu-ignore

cdp enable

tunnel source GigabitEthernet

tunnel destination IP

!

Now it`s imposible for me to try the ping, but as well as it`s posible I`m going to try it.

Hope you can help me with this and thanks.

Community Member

Re: Problems with OSPF adjacency

Thank you, but the problem is resolved it was a line problem.

But thank you all anyway!!

Community Member

Re: Problems with OSPF adjacency

Hi,

I assume your tunnel interface is up in both the end, and both the IP is reachable.

Then, remove tunnel interface network from router ospf xx  , and give the ospf command in interface level ( like under interface tunnxx ,  ip ospf area xx ) ,then see the status.

If it is not working , please forward the output of    debug ip ospf adj  output as well.

Best Regards,

M.I.

Community Member

Re: Problems with OSPF adjacency

Ok , I thought it was not resolved. thanx.

One Question : you had told earlier , you had recieved authentication mismatch , if it was line problem why did u say authentication mismatch ?

Regards,

M.I.

1028
Views
0
Helpful
8
Replies
CreatePlease to create content