Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Pruning vlan

Can anyone explain what exactly do i achieve with the pruning configuration listed below when there are only specific vlans allowed on the trunk?

interface FastEthernet5/28

switchport access vlan 102

switchport trunk encapsulation dot1q

switchport trunk native vlan 102

switchport trunk allowed vlan 102,120

switchport trunk pruning vlan 2-101,103-119,121-1000

switchport mode trunk

switchport voice vlan 120

speed 100

duplex full

qos trust dscp

Thanks

4 REPLIES
Hall of Fame Super Blue

Re: Pruning vlan

Hi

As far as i can see you don't achieve anything. Pruning is useful to sutomatically stop vlan traffic being propogated down links when that vlan is not in use at the far end of the link but as you have specifically only allowed vlan 102 and 120 traffic then i would say the pruning is unnecessary.

Jon

Re: Pruning vlan

It would help when you have pruning enabled but you do not configure the switchport trunk allowed vlan command under the interface

Narayan

Community Member

Re: Pruning vlan

Hi,What if a switch and its downstream switches dont have any access ports for vlan 100(for example).in this case pruning avoids unnecessary traffic for vlan100 over the trunks.

Re: Pruning vlan

You are right but when we allowe only specific vlans over the trunk using the switchport trunk allowed vlan command, pruning would be unnecessary.

Even if do not prune for eg vlan 200, it will not be allowed over thetrunks due to the above command

HTH

Narayan

164
Views
0
Helpful
4
Replies
CreatePlease to create content