Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Public IP & NAT

Our ISP has provided us with a public IP.

I have connected their Modem of a Cisco router 1710, and the second port (FastEthernet) to our internal network.

I have Natted the public IP to one of the PCs inside our network, so that the outside world can reach the PC.

Is it possible that a connection on a specific port on the public IP addr. is natted to a second PC.

eg:

http://'IP Address':8080 goes to PC1

http://'IP Address':8000 goes to PC2

How to configure the router?

thx

1 REPLY
Silver

Re: Public IP & NAT

interface F0/0

description connection to ISP

ip address 1.1.1.1 255.255.255.252

ip nat outside

interface F0/1

description Internal LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 100 interface F0/0 overload

ip nat inside source static tcp 192.168.1.10 8080 interface FastEthernet0/0 8080

ip nat inside source static tcp 192.168.1.20 8000 interface FastEthernet0/0 8000

where

192.168.1.10 = PC1

192.168.1.20 = PC2

CCIE Security

107
Views
0
Helpful
1
Replies