Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

PVST --> RSTP migration query

Hello experts,

Scenario- Single Cisco 4507R Dist/core SW for the location.Got two L3 gig links to DC and DR. Upto 7 Access switches with Primary path as Fiber link Trunk and backup RJ-45 Trunk. 4507 is spanning tree Root (with lowered STP priority) and access switches set to higher priority.

Below is config ex:

_____________________________________________________________

!
interface GigabitEthernet2/1
description :GIG L3 to DR (4507R)
no switchport
ip address 10.1.1.2 255.255.255.252
end

!
interface GigabitEthernet3/16
description :GIG L3 to DC (6513)
no switchport
ip address 10.1.5.2 255.255.255.252
!
interface GigabitEthernet3/1
description :TRUNK TO 3560-S1 Gig 0/49
switchport trunk encapsulation dot1q
switchport mode trunk

!

interface GigabitEthernet7/48
description :TRUNK (BACKUP) TO 3560-S1 Gig0/48
switchport trunk encapsulation dot1q
switchport mode trunk
!


spanning-tree summary:

Switch is in pvst mode
Root bridge for: VLAN0001, VLAN0005, VLAN0010, VLAN0015, VLAN0020, VLAN0025,  VLAN0030, VLAN0133, VLAN0150-VLAN0152, VLAN0155-VLAN0158, VLAN0160

________________________________________________________________

All switches running PVST and planning to migrate to RSTP.

The below commands work with no issues? (with a maintenanace window)

Step 1. Access switches:

spanning-tree mode rapid-pvst

Step2. 4507:

spanning-tree mode rapid-pvst


Or do I need to enable RSTP on Core 1st?

What about the access switches that is running port- channel to core. Any addl config required for these switches?

L3 links should have no impact with any of these changes. Is that correct?

Thanks in advance

MS

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PVST --> RSTP migration query

I converted our STP from standard IEEE STP 802.1d to 802.1w RPVST+. It's really pretty easy, but I would recommend doing this during a maintenance window. I went to each of are access switches and one by one converted them over. I made sure each had connectivity before going on to the next. Also, once you are done, I would recommend doing a 'show spanning-tree vlan x'   X being the VLAN of your choice. Sometimes the port may still be in STP mode. If you have any of those switches there is a command to get it to check the STP version again.

4 REPLIES

Re: PVST --> RSTP migration query

read the below official doc

http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a00807b0670.shtml

Sent from Cisco Technical Support iPad App

Re: PVST --> RSTP migration query

Hi Andrew,

Thank you for checking on this. I already went thru this doc and the steps/commands got from the same. The reason I posted the query is to get some sugesstions from those who implemented such migration...

1. To make sure there will not be any surprises during the migration for the simple setup like the described scenario

2. Wanted to check any additional config necessary for Port channeled switches and to make sure that this confg has nothing to do with L3 links.

Thanks again

MS

Re: PVST --> RSTP migration query

I converted our STP from standard IEEE STP 802.1d to 802.1w RPVST+. It's really pretty easy, but I would recommend doing this during a maintenance window. I went to each of are access switches and one by one converted them over. I made sure each had connectivity before going on to the next. Also, once you are done, I would recommend doing a 'show spanning-tree vlan x'   X being the VLAN of your choice. Sometimes the port may still be in STP mode. If you have any of those switches there is a command to get it to check the STP version again.

PVST --> RSTP migration query

Thanks John.

448
Views
0
Helpful
4
Replies
CreatePlease login to create content