Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Q-in-Q with only ONE switch. Will it work or not?

Hello

If I configure catalyst 3560 like this:

interface fa0/1

switchport mode access

switchport access vlan 1

interface fa0/2

switchport mode access

switchport access vlan 2

interface fa0/3

switchport mode access

switchport access vlan 3

interface fa0/22

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan add 1-10

interface fa0/23

switchport access vlan 312

switchport mode dot1q-tunnel

interface fa0/24

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan add 312

and then connect port 22 and 23 with patch-cord, will traffic on port 24 be Q-in-Q incapsulated?

Everyone's tags (1)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Q-in-Q with only ONE switch. Will it work or not?

Hi Alexandr,

I am not sure why you want to do it like this but that should work. The packest leaving port 24 should have 2 tags, External 312 and Internal (1-10).

JayaKrishna

Bronze

Re: Q-in-Q with only ONE switch. Will it work or not?

Hi Alexandr,

You config should work. We have the same config in our network working fine without any issues.

HTH

Arun

Cisco Employee

Re: Q-in-Q with only ONE switch. Will it work or not?

I think with some of the later code this works on the 3560/3750.

A few years ago I saw some issues with it when double tagged frames come into the switch with dest mac and IP of the switch...I think we were trying to telnet to it from a device across the tunnel.  Instead of switching the traffic out again to a tunnel to decap it, we instead were sending it directly to the CPU...which couldn't understand the frame due to the doubletagging, and dropped it.

The soultion worked for traffic going through the switch, but ultimatly some managment issue were the only pain point from across the tunnel...now I'm not sure if that problem still exists.  Just something to keep an eye on.

I'm pretty sure  a co-worker of mine tested this again recently and didn't encounter the issue I saw a few years ago.  I didnt get a chance to look at his setup, but looks like it may work like you'd expect now.

6 REPLIES
Cisco Employee

Re: Q-in-Q with only ONE switch. Will it work or not?

Hi Alexandr,

I am not sure why you want to do it like this but that should work. The packest leaving port 24 should have 2 tags, External 312 and Internal (1-10).

JayaKrishna

New Member

Re: Q-in-Q with only ONE switch. Will it work or not?

I am not sure why you want to do it like this

Because I don't want to buy two switches, when enough only one

You can look at pictures of my network config here:

https://supportforums.cisco.com/thread/2035034

Bronze

Re: Q-in-Q with only ONE switch. Will it work or not?

Hi Alexandr,

You config should work. We have the same config in our network working fine without any issues.

HTH

Arun

New Member

Re: Q-in-Q with only ONE switch. Will it work or not?

Sorry ...wrong question

Cisco Employee

Re: Q-in-Q with only ONE switch. Will it work or not?

I think with some of the later code this works on the 3560/3750.

A few years ago I saw some issues with it when double tagged frames come into the switch with dest mac and IP of the switch...I think we were trying to telnet to it from a device across the tunnel.  Instead of switching the traffic out again to a tunnel to decap it, we instead were sending it directly to the CPU...which couldn't understand the frame due to the doubletagging, and dropped it.

The soultion worked for traffic going through the switch, but ultimatly some managment issue were the only pain point from across the tunnel...now I'm not sure if that problem still exists.  Just something to keep an eye on.

I'm pretty sure  a co-worker of mine tested this again recently and didn't encounter the issue I saw a few years ago.  I didnt get a chance to look at his setup, but looks like it may work like you'd expect now.

New Member

Re: Q-in-Q with only ONE switch. Will it work or not?

Many thanks to all!

1833
Views
0
Helpful
6
Replies
CreatePlease to create content