Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Q0S with VLAns

Hello Experts,,,Guys..

We have Centralized network with 4 different location, each location is conected via MPLS cloud..on each site we are using 2600 /2800 routers and 3750 stacked switches.. switches with default vlans are working fine..we also have 20 to 30 IP phone users in same default VLAN...

Now I decide to create a spreat VLAN for voice ..so wot I need to do is access switch..Vlan database

Vlan 2 name IP phones

#int vlan 2

#ip address 10.1.1.1 255.255.255.0

#nno shut

#int g0/0/2

#switchport mode access

#switch port access vlan 2

#ip route 0.0.0.0 0.0.0.0 10.9.1.1 (GW)

I test this config on simulator which is working fine..but question is do I need to config QoS..Management also want QoS over the MPLS links...

So I am totally confused now..I never touch QoS before..don't know wot to do..

Some 1 help me please ...at least advise on voice VLANs would be highly appreciated....

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Q0S with VLAns

I'm glad that it does - please remember to rate helpful posts

Regards

Edison.

7 REPLIES
Hall of Fame Super Bronze

Re: Q0S with VLAns

I recommend you to read the following article on QoS:

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoS-SRND-Book.html

As for your current design, I recommend configuring your switchport with voice and data as you will connect the IP-Phone to the switchport but this IP-Phone will have a connection to a data device in the back-end. The IP-Phone will serve as a bridge for this data connection.

Your swithport configuration will look like:

interface g0/0/2

switchport

switchport mode access

switchport access vlan 3 (data)

switchport voice vlan 2 (voice)

Regards

Edison.

Community Member

Re: Q0S with VLAns

Thanks Edison,

I am confused here.hope you will remove this confusion..

As I mention erlier we have 4 branches in datacenter we are using 10.1.1.x series via default vlan all L3 switches have i.e. 10.1.1.5 10.1.1.10 etc.. switches are on default vlan say 1 of the switch have 10.1.1.5 IP default-gateway is 10.1.1.1 whichh is the IP for Router where MPLS is terminatin from ISP is in the same switch we are using IP route 0.0.0.0 0.0.0.0 10.1.1.1.

now in other branch same scenario say london branch 10.6.1.1 is router f0/0 and it is connecting with the L3 swicth using 10.6.1.10 on default vlan on the same switch ISDN is terminating phonees are also connected. I decide to create VLAN on all the branches for phones say branch 1 where we are using 10.5.1.x create Vlan 2 name phone use 10.55.1.x range in london create vlan 2 name phone use 10.66.1x in my lab sim I produce the network evry thing is OK excep new vlans..they cannot ping each others i.e. in london when I am creating 10.66.1.1 and user is having 10.66.1.5 ip user is not able to ping gateway which is 10.66.1.1 but from the switch I am able to ping 10.66.1.5 same case with every branch..we are not using management vlans and I don't want to go there to make it more complicated..i think its intervlan routing issue..or technically we cannot ping default vlans..

Will you please advise here what should I do..where i am missing and what points..

Your advise will be highly appreciated..

Regards

Jag

Hall of Fame Super Bronze

Re: Q0S with VLAns

A typical switch configuration to support ip-phones would be:

vlan 2

name ip-phone

!

vlan 3

name data

!

interface vlan 2

ip address 10.1.66.1 255.255.255.0

!

interface vlan 3

ip address 10.1.6.1 255.255.255.0

!

ip routing

!

interface fx/x

switchport mode access

switchport access vlan 3

switchport voice vlan 2

With this design, 10.1.6.x should be able to ping 10.1.66.x. To be on the voice vlan, you must configure the DHCP server with the 'ip-phone dhcp option', you must consult your ip-phone configuration on that.

As for the router being able to ping back to those subnets, you must either have a static route from the router back to those subnets or configure dynamic routing protocol between the switch and the router.

If this does not make sense, I highly recommend getting a consultant to be onsite for this deployment.

Regards

Edison

Community Member

Re: Q0S with VLAns

Thanks Edison,

Its all make sense..Thank you so much..

Regards,

Jag

Hall of Fame Super Bronze

Re: Q0S with VLAns

I'm glad that it does - please remember to rate helpful posts

Regards

Edison.

Community Member

Re: Q0S with VLAns

I have seen the big mistake in most cases be something easy like a device that does not have routing turned on. I knwo it is silly but I was called into a situation where they were adding vlans to a location that only had 1 default vlan and they never added that critical command IP Routing on the device. Most people will not admit it when they do things like these but it happens!!!!!!!

Community Member

Re: Q0S with VLAns

Hi Gfremgen,

Totally agree with you, this was the command I stuck googling and reading my CCNA books ...why vlan is not reaching to default vlan..last week I was discussing with my friend and he pointed out this mistake IP routing..I can now reach to my switch from end users with in the vlans to switch but can not ping to the gateway ..I am sure its because my simulator is not recognizing ip route 0.0.0.0 0.0.0. x.x.x.x(gateway)?? Once I confirm this I'll deploy this in prod enviornment...

Hope you understand and might confirm this?..

Regards

305
Views
1
Helpful
7
Replies
CreatePlease to create content