Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS - cisco ip phone and map tables

I have a few questions that I need help with.

 

1) If using a  7940 phone, it sets the CoS bit only (?) to 5, correct?  It doesn't actually set a dscp value too, correct? 

2) The switch maps the cos to dscp values internally using the map table, correct?

3) Can someone please explain and breakdown these two lines from my config?

mls qos map policed-dscp  0 10 18 24 46 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

 

Thank you,

3 REPLIES

Hey,Regarding your questions

Hey,

Regarding your questions:

1) If using a  7940 phone, it sets the CoS bit only (?) to 5, correct?  It doesn't actually set a dscp value too, correct? - Yes you are correct.

2) The switch maps the cos to dscp values internally using the map table, correct? - Indeed it uses the cos-dscp maps for translation.

3) Can someone please explain and breakdown these two lines from my config?

mls qos map policed-dscp  0 10 18 24 46 to 8 - Looks like you have a policer applied and if it exceeds the limit DSCP values 0,10,18,24,26 will be remarked to 8.

mls qos map cos-dscp 0 8 16 24 32 46 48 56 - Its a cos to dscp map i.e Cos0 is mapped to DSCP0, Cos8 is mapped to DSCP16....so on till Cos7 mapped to DSCP56 .

New Member

 Awesome. Just a bit more..1)

 

Awesome. Just a bit more..

1)  In regards to the "mls qos map policed-dscp  0 10 18 24 46 to 8" why does AutoQos change 46 to 8? Isn't 46 already EF?  This is where I may be misunderstanding the map table.

2) Why does policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY have the class under it called AUTOQOS_VOIP_DATA_CLASS with an action to set dscp ef when there is already a class-map called AUTOQOS_VOIP_DATA_CLASS that is matching on EF already?  Doesn't that make the policy statement useless? Config snippets below.

mls qos map policed-dscp  0 10 18 24 46 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 70 30
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input cos-map queue 1 threshold 2 3
mls qos srr-queue input cos-map queue 1 threshold 3 6 7
mls qos srr-queue input cos-map queue 2 threshold 1 4
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos

class-map match-all AUTOQOS_VOIP_DATA_CLASS
 match ip dscp ef 
class-map match-all AUTOQOS_DEFAULT_CLASS
 match access-group name AUTOQOS-ACL-DEFAULT
class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
 match ip dscp cs3 
!
!
policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
 class AUTOQOS_VOIP_DATA_CLASS
  set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_VOIP_SIGNAL_CLASS
  set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_DEFAULT_CLASS
  set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit

interface FastEthernet1/0/1
  switchport mode access
 switchport voice vlan 200
 srr-queue bandwidth share 1 30 35 5
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

Hey,Sorry for the delays, i

Hey,

Sorry for the delays, i was little occupied. Now regarding your queries, i believe you have configured the following command:

#auto qos voip cisco-phone

I checked the configuration guide for a 3750 switch and it looks like following:

Switch(config)# mls qos map policed-dscp  0 10 18 to 8 - So no 46 here
Switch(config)# mls qos map cos-dscp 0 8 16 24 32 46 48 56

!
Switch(config)# class-map match-all AUTOQOS_VOIP_DATA_CLASS
Switch(config-cmap)# match ip dscp ef

Switch(config)# class-map match-all AUTOQOS_DEFAULT_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-DEFAULT
Switch(config)# class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-cmap)# match ip dscp cs3
Switch(config)# policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
Switch(config-pmap)# class AUTOQOS_VOIP_DATA_CLASS
Switch(config-pmap-c)# set dscp ef

Switch(config-pmap-c)# police 128000 8000 exceed-action policed-dscp-transmit


Switch(config-pmap)# class AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)# police 32000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_DEFAULT_CLASS
Switch(config-pmap-c)# set dscp default
Switch(config-pmap-c)# police 10000000 8000 exceed-action policed-dscp-transmit
Switch(config-if)# service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

!

Regarding the other question, sometimes due to qos state configured on the port the internal DSCP value, which is used to make QoS decision be switch, may change. So another set dscp ef is to make sure that voice traffic should leave switch marked as EF.

HTH.

Regards,
RS.

 

115
Views
0
Helpful
3
Replies