Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

qos clarification about cisco 7609

Hi,

Scenario like below

(Vlan284)Gi2/5 7609A GE-WAN3/1--------------------------- Gi2/4 7609B

7609A#

interface gi2/5

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust cos

!

interface Vlan284
mtu 4474
bandwidth 2000
no ip address
load-interval 30
xconnect 120.124.0.1 1005931 encapsulation mpls
service-policy input TEST_284

!

Policy Map TEST_284
    Class class-default
     police cir 2000000 bc 375000
       conform-action set-mpls-exp-imposition-transmit 0
       exceed-action drop

!

interface GE-WAN3/1

ip address 120.124.16.113 255.255.255.252

mls qos trust dscp

service-policy output GE-Out

!

policy-map GE-Out
  class Platinum
    priority
  class Gold
    bandwidth remaining percent 33
     random-detect
     random-detect exponential-weighting-constant 13
     random-detect precedence 4 5833 6667 10
     random-detect precedence 6 3333 5833 10
     random-detect precedence 7 3333 5833 10
    queue-limit 16384 packets
  class Silver
    bandwidth remaining percent 53
     random-detect
     random-detect exponential-weighting-constant 13
     random-detect precedence 2 4167 6667 10
     random-detect precedence 3 6667 7500 10
    queue-limit 16384 packets
  class Bronze
    bandwidth remaining percent 14
     random-detect
     random-detect exponential-weighting-constant 13
     random-detect precedence 0 3800 5000 10
     random-detect precedence 1 2200 3800 10
    queue-limit 16384 packets

!

7609B#

interface GigabitEthernet2/4

ip address 120.124.16.114 255.255.255.252

mls qos trust cos

!

-------------------------------------------------------------------------------------------------------------

If you clear see the above connectivity and configuration, customer Vlan 284 is hitting Gi2/5 interface on 7609A device. Here we are trusting COS value and putting mpls exp 0 while sending customer packet out via GE-WAN3/1.

But 7609B Gi2/4 is configured to trust COS value. As there in no COS value on non trunk port, what QoS action applies on customer packet upon receipt at 7609B Gi2/4 interface?

Regards

Siva

Everyone's tags (3)
4 REPLIES

qos clarification about cisco 7609

I am just studying CoS/QoS, so dont take this to the bank, but I believe it will be assigned the default value for untagged packets with no markings.  If its tagged, packet remains unaltered.  Look forward to other opinions.....

http://www.cisco.com/en/US/docs/switches/lan/catalyst2940/software/release/12.1_19_ea1/configuration/guide/swqos.html#wp1025595

Default QoS Configuration

This is the default QoS configuration:

The default port CoS value is 0.

The default port CoS value is assigned to all incoming untagged packets. The CoS value of each tagged packet remains unaltered.

Gold

qos clarification about cisco 7609

Hi Siva,

in your configuration, you set your ingress ports to trust cos n dscp values, then you used policy maps to enforce a bandwidth limit and do a congestion management via Random Early Detection for your egress inteface (GE-WAN).

As far as im concerned you haven't set any kind of QoS methods on the ingress int Gi2/4 that it may need to use either CoS or DSCP values. what sort of behavior do you exactly mean?

correct me if im wrong or got your question wrong

by the way when you set the mls qos trust cos on an interface, you instruct it to classify traffic by examining the (CoS) or (DSCP) value, and if there is already nothing there, it assigns the default value of 0, unless u configure it otherwise.

plz Rate if it helped,

Soroush.

Hope it Helps, Soroush.
New Member

qos clarification about cisco 7609

Hi,

When tagging customer traffic with Vlan284 on metro ethernet switch assigning COS 0. When same packet is hitting PE router where xconnect is configured I am trusting COS value, there policing customer traffic and assigning MPLS EXP 0.

Forgot to post class-map configuration, please see below. On egress port towards core, this customer traffic is treated by Bronze class.

7609A# sh class-map Bronze

Class Map match-any Bronze (id 2)

   Match   dscp default (0) cs1 (8)

   Match mpls experimental topmost 0  1

   Match ip  precedence 0  1

I wanted to retain same behavior through out core.

If you see 7609B configuration, it is configured to trust COS value. But I am sending packet with MPLS EXP 0 value. When happens to MPLS EXP value after received it by 7609B ingress port?  I didn't see option to trust MPLS EXP value.

Regards

Siva

Gold

qos clarification about cisco 7609

Hi,

So, you have a MPLS core... this is what happenes to the EXP bits when packets enter and pass through MPLS networks:

Imposition of Label (IP –> Label):

  • The IP precedence of the incoming IP packet is copied to the MPLS EXP bits of all pushed label(s).
  • The 1st three bits of the DSCP bit is copied to the MPLS EXP bits of all pushed label(s).
  • This technique is also known as ToS Reflection.

MPLS forwarding (Label –> Label):

  • The EXP is copied to the new labels that are swapped/pushed during forwarding or imposition.
  • At label imposition, the underlying labels are not modified with the value of the new label being added to the current label stack.
  • At label disposition, the EXP bits are not copied down to the newly exposed label EXP bits.

Disposition of Label (Label –> IP):

  • At label disposition the EXP bits are not copied down to the IP precedence/DSCP field of the newly exposed IP packet.

For QoS and PHB in the MPLS Core, read in this link:

http://www.cisco.com/en/US/tech/tk436/tk428/technologies_tech_note09186a008022ad7e.shtml

plz Rate if it helped.

Soroush.

Hope it Helps, Soroush.
965
Views
0
Helpful
4
Replies