Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS classify BGP traffic on Catalist3750

Hi,

QoS classify BGP traffic on Catalist3750 not work.

mls qos
!
interface FastEthernet1/0/24  <- Output Interface
switchport mode access
srr-queue bandwidth share 10 60 40 5
mls qos trust dscp
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0

Other QoS setting is default, and Catalist3750 run BGP.

Switch#sh mls qos int fa 1/0/24 stat
(snip)
  output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------
queue 0:           2           0           0
queue 1:        1140        2421         777
queue 2:           0           0           0
queue 3:           0           0           0

BGP Traffic through Catalist3750 enqueued queue3, but BGP Traffic from Catalist3750 itself
enqueued queue1 (default queue).

Am I missing something?

Thanks.

Everyone's tags (2)
2 REPLIES
Hall of Fame Super Bronze

Re: QoS classify BGP traffic on Catalist3750

Routing Protocols and Layer2 features such as Spanning-Tree are placed on a special queue when they are generated by the router.

This information can't be seen with the regular show mls qos commands.

In order to see the packet has the correct marking, inspect the header information while it is being received at the remote end.

I did a quick test to verify if the BGP packets were coming as dscp 0 or dscp cs6.

Rack1SW1#sh run | i access-list 101
access-list 101 permit tcp any any eq bgp dscp default
access-list 101 permit tcp any any eq bgp dscp cs6
access-list 101 permit tcp any eq bgp any dscp cs6
access-list 101 permit tcp any eq bgp any dscp default

Rack1SW1#debug ip packet 101 det

Rack1SW1#sh ip access-lists 101
Extended IP access list 101
    10 permit tcp any any eq bgp dscp default
    20 permit tcp any any eq bgp dscp cs6
    30 permit tcp any eq bgp any dscp cs6
    40 permit tcp any eq bgp any dscp default

Few seconds later

Rack1SW1#sh ip access-lists 101
Extended IP access list 101
    10 permit tcp any any eq bgp dscp default
    20 permit tcp any any eq bgp dscp cs6 (2 matches)
    30 permit tcp any eq bgp any dscp cs6 (20 matches)
    40 permit tcp any eq bgp any dscp default

Regards

Edison

New Member

Re: QoS classify BGP traffic on Catalist3750

Hi,

thanks for your reply.

I captured packets from Catalyst3750, and those packets had correct marking, dscp cs6.

I did a test to check if BGP packet priority over other packet, I used Smartbit to inject a flow into link, marked with dscp cs0.

The WAN link congested, but BGP neighbor , between Catalyst3750 and remote end router, never down.

Thanks.

2433
Views
0
Helpful
2
Replies
CreatePlease login to create content