Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Qos configuration based on access-list

Hi,

I am trying to configure Qos on the edge router based on access-list with specific bandwidth allocation. The problem is the traffic is not hiiting specific Class Map. Here is my config:

ip access-list extended TELEPHONY
permit tcp any any eq 135
permit tcp any any eq 1025
permit tcp any any eq 1026
permit tcp any any eq 389
permit tcp any any eq 137
permit udp any any eq 88
permit udp any any eq 53
permit tcp any any eq 53
permit tcp any any eq 25
exit

ip access-list extended IT_ADMIN
permit tcp any any eq 10000
permit tcp any any eq 6101
permit tcp any any eq 2100-22000
permit tcp any any eq 8014
permit tcp any any eq 9090
permit tcp any any eq 2638
permit tcp any any eq 1433
permit tcp any any eq 2967
permit tcp any any eq 8005
exit

ip access-list extended IT_CRITICAL
permit tcp any any eq 22
permit tcp any any eq 23
permit tcp any any eq 6129
permit udp any any eq 161
permit tcp any any eq 162
permit tcp any any eq 89
exit


ip access-list extended BUSINESS
permit tcp any any eq 135
permit tcp any any eq 136
permit tcp any any eq 137
permit tcp any any eq 138
permit tcp any any eq 139

permit tcp any any eq 445
exit

ip access-list extended CLINICAL
permit tcp any any eq 3389
permit tcp any any eq 1433
exit


ip access-list extended OTHER
permit tcp any any eq 515
permit tcp any any eq 631
permit tcp any any eq 9100
permit tcp any any eq 25
permit tcp any any eq 110
permit tcp any any eq 80
exit


class-map  TELEPHONY
match access-group name TELEPHONY
exit
class-map  IT_ADMIN
match access-group name IT_ADMIN
exit

class-map  IT_CRITICAL
match access-group name IT_CRITICAL
exit

class-map  BUSINESS
match access-group name BUSINESS
exit


class-map  CLINICAL
match access-group name CLINICAL
exit


class-map  OTHER
match access-group name OTHER
exit

policy-map Serha
class TELEPHONY
bandwidth 2000
class IT_ADMIN
bandwidth 1500
class IT_CRITICAL
bandwidth 1500
class BUSINESS
bandwidth 3500
class CLINICAL
bandwidth 3500
class OTHER
bandwidth 1500


interface gigabitEthernet 0/0
service-policy output Serha
exit

Anybody has any idea?

Thanks.

5 REPLIES
Hall of Fame Super Blue

Re: Qos configuration based on access-list

I am trying to configure Qos on the edge router based on access-list with specific bandwidth allocation. The problem is the traffic is not hiiting specific Class Map. Here is my config:

Could you be more specific. Which access-lists are not being hit and what type of device are you using ?

Jon

Community Member

Re: Qos configuration based on access-list

Hi Jon.

All the traffic is going to the Class-Default, none of the traffic is hitting the right Class- Map. For example I tried to test with telnet traffic but It didn't hit right Class- Map, It went to the Class-Default. I am using ISR 2811 router.

Thanks.

Hall of Fame Super Blue

Re: Qos configuration based on access-list

mrahman0302 wrote:

Hi Jon.

All the traffic is going to the Class-Default, none of the traffic is hitting the right Class- Map. For example I tried to test with telnet traffic but It didn't hit right Class- Map, It went to the Class-Default. I am using ISR 2811 router.

Thanks.

So you are doing this -

client ->  (gi0/1) 2821 (gi0/0) -> remote device

where service-policy is applied to gi0/0 and you are telnetting from the client to the remote device ?

Jon

Community Member

Re: Qos configuration based on access-list

Hi Jon,

I am some host behind the router (fas0), I am test setup like this:

Client-------Switch-------Router-----------Destination Host ( RDP or Telnet or HTTP)

Yes, client is telnetting to the remote device.

Community Member

hiii ,here im asking about

hiii ,

here im asking about something.

 

i found that you have done marking on an interface , then u applied the policymap on  based on the matched scp values.

 

 

im asking here .... if you directly applied QOS based on "out" direction

what will happen ?

 

 

is it better to make mark 1st ?

or the same thing ?

 

regards

796
Views
0
Helpful
5
Replies
CreatePlease to create content