Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS, Etherchannel and Supervisor 6E

I am trying to include trunk ports into an etherchannel with a QoS input and output policy. Every attempt to put it into the channel-group fails because the physical interface has a service-policy attached to it.

I've tried to put the input/output service policies on the Port Channel virtual interface, but it only allows me to put the input policy on, not an output policy.

If I have any service-policy defined on the physical interfaces, it will not join the channel-group.

The interfaces are Layer 2 trunk ports to a 6509 and the Etherchannel is Layer 2 only.

With QoS enabled on the switch, will all the QoS markings be trusted by default over these trunks and therefore don't need to have the policies defined?

Its a Catalyst 4506E with Sup 6E.

interface Port-channel1

description L2 Etherchannel for trunk to 6509

switchport

switchport trunk native vlan 999

switchport mode trunk

!

interface GigabitEthernet3/47

description L2 trunk to 6509

switchport trunk native vlan 999

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode desirable

!

interface GigabitEthernet5/47

description L2 trunk to 6509

switchport trunk native vlan 999

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode desirable

1 REPLY
Blue

Re: QoS, Etherchannel and Supervisor 6E

Im no QoS guru, but I can tell you that you should identify your traffic, mark it, and then apply a policy to it as close to the origin as possible.

Then, at each successive hop (layer 2 or L3), you will want to use the "mls qos trust cos" command (switched ports) or the "mls qos trust dscp | ip precedence" command (routed ports) to extend the trust boundary. By default, a port does not trust the CoS/QoS markings of the packet it receives.

As far as why you cant apply a policy in the outbound direction or why you cant apply it t the port channel, I will have to investigate.

Qute frankly I have always wondered why certain switch platforms do not allow you to apply a QoS policy in the outbound direction....seems strange.

Hope I was of some help.

[EDIT] To the QoS expert who will answer the call for help, if I am incorrect about anything, please let me know. Thanks. [EDIT]

Victor

564
Views
0
Helpful
1
Replies
CreatePlease to create content