Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS for Avaya Phones on Catalyst 4510 with Sup 7E

We recently purchased some 4510s for some of our larger branch offices. Our Telecom department favors Avaya so we have a bunch of Avaya 9600 series IP phones. We were just assuming we'd use autoQoS but that is not an option on the Sup 7E. I'm trying to build a very basic MQC QoS config that only fixes the COS value from 6 to 5. I want to leave the default queueing alone. The Avaya phone tags as DSCP 46 and COS 6. Anyone have a working config they can share? I tried the following but it didn't seem to work, a packet capture still showed COS 6 coming from the port:

class-map match-any VoIP

match dscp ef

policy-map SET-COS

class VoIP

set cos 5

int gi1/1

service-policy input SET-COS

Thanks,

Rob

Everyone's tags (4)
3 REPLIES
Hall of Fame Super Blue

QoS for Avaya Phones on Catalyst 4510 with Sup 7E

Rob

Where are you doing the packet capture in relation to int gi1/1 ?

Can you post full config of gi1/1  ?

What IOS version are you using on the 4500s ?

Jon

New Member

QoS for Avaya Phones on Catalyst 4510 with Sup 7E

Hi Jon,

Thanks for your response. The full config for gi1/1 is:

interface GigabitEthernet1/1

switchport access vlan 100

switchport voice vlan 101

spanning-tree portfast

service-policy input SET-COS

end

We did the packet capture using a Fluke Omniview attached to a span port set with dot1q encapsulation. The IOS version is cat4500e-universalk9.SPA.03.02.05.SG.150-2.SG5.bin. We're just trying to respect the DSCP 46 (EF) tag presented by the phones and pass it as COS 5 also.

Thanks,

Rob

Hall of Fame Super Blue

QoS for Avaya Phones on Catalyst 4510 with Sup 7E

Rob

Apologies for the delay but i had to read up on the new QOS on 4500s. I can't see what's wrong with your config. The only thing i found was this from the config guide -

set Commands

Traffic Attribute

Packet Type

set cos

Layer 2 CoS value of the outgoing traffic

Ethernet IPv4, IPv6

set dscp

DSCP value in the ToS byte

IPv4, IPv6

set precedence

precedence value in the packet header

IPv4, IPv6

set qos-group

QoS group ID

Ethernet, IPv4, IPv6

Some of the documentation seems to suggest you can set CoS on ingress but the above is saying you can only set on outgoing traffic.  The config guide cover the 6-E and 6-LE but i can't seem to find one for the 7L, unless it hasn't changed.

I'll keep searching but If all the traffic is going out a trunk link it may be worth trying to set the CoS value there instead of inbound, especially as you are not looking to do any queueing etc. on the switch.

Jon

416
Views
0
Helpful
3
Replies
CreatePlease to create content