Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Qos help

Hello,

We are using 2960s switch on which QOS was configured as follows.

mls qos map policed-dscp  0 10 18 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20

user port:

interface GigabitEthernet1/0/7
description ### DATA ZONE - 1 ###
switchport access vlan 31
switchport mode access
switchport voice vlan 131
switchport port-security maximum 11
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
ip arp inspection limit rate 100
srr-queue bandwidth share 1 30 35 5
queue-set 2
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description AccessEdgeQoS
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
ip verify source
ip dhcp snooping limit rate 100

As per my understanding  2960s switch do not support ingress queuing.Here all qos mappng commands are configured as egress queuing but service -policy on user port configured as input policy.

I need help on this.

4 REPLIES
New Member

Qos help

you would have to look at the service policy. With srnd4, when you enter(ed) auto qos voip cisco-phone on this interface, the service policy gets applied. I believe all it does is match markings and then set input rate limits, but I haven't looked over this in a while and am going from memory.

chris

New Member

Qos help

Hello Chris,

Thank you for your reply,

You r right with auto qos voip cisco-phone command applied service-policy.But here service policy applied as inbound direction where ingress queuing on 2960 switch is not supportable,it must be in output direction?

New Member

Qos help

Jeevak,

the service policy is not actually queueing. The queues are assigned on egress via the following under the interface:

srr-queue bandwidth share 1 30 35 5

queue-set 2

priority-queue out

the service policy is doing classification/marking on ingress, and also policing to specific bandwidths. That's perfectly fine,

because based on the ingress markings, it will get assigned to a transmit queue elsewhere (IE-uplink to network, or other edge port on the switch, if that's where the destination is).

At least that's my understanding - chris

Super Bronze

Re: Qos help

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

What Chris wrote is basically correct, although to clarify, either there's just one egress queue, when QoS is disabled, or four egress queues, when QoS enabled.

The interface configurations noted by Chris, define the dequeuing scheduling treatment between the four queues and which queue-set to use for other resource configuration options (defined globally).

307
Views
0
Helpful
4
Replies
CreatePlease login to create content