Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS implementation question between core switch and access switch

Hi,

Am working on implementing QoS in a building in our district. Which switches need this command: ?mls qos trust dscp? and what switch needs ?Auto Qos? enabled?

Here is the breakdown of this buildings network:

1 - Cat 3750 - core switch w/ IP routing enabled (only 12 gig ports)

4 - Cat 3560 - access switches with PoE ports for our phones and some data ports

4 - Cat 3550 - access switches - data ports

2 - Cat 2950 - access switches - data ports

Here is the auto QoS config from the Cat3560 ? an access layer switch.

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2 1

mls qos srr-queue input cos-map queue 1 threshold 3 0

mls qos srr-queue input cos-map queue 2 threshold 1 2

mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3 3 5

mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3 32

mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

!

(text deleted)

!

interface FastEthernet0/1

description VLAN 110: IP phone

power inline never

switchport access vlan 110

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

!

interface FastEthernet0/2

description VLAN 110: IP phone

power inline never

switchport access vlan 110

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

Should Auto Qos be enabled on each switch that supports it?

Thanks for any help

Dan

3 REPLIES
New Member

Re: QoS implementation question between core switch and access s

I also recommend "auto qos voip trust" configured on your 3560's uplink port to the 3750G-12S.

Do you also have CCM server connected somewhere? Or are you using CME?

New Member

Re: QoS implementation question between core switch and access s

Thanks for the tip. I'll put it in there tomorrow. By CCM do you mean cisco call manager. Or is CME - Call manager express?

Dan

New Member

Re: QoS implementation question between core switch and access s

I have "auto qos voip trus" configured on one of the 3560 switch's uplink ports. Do you think I need the massive config of auto qos --mls qos map....mls qos srr-queue input bandwidth....all of those commands generated from auto qos. Do I need those on the 3560 or on the 3750 Core switch?

A cisco engineer working on our other buildings in our district sent a sample config for a 3560 with these configs (a short config):

msl qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos map ip-prec-dscp 0 8 1624 32 46 48 56

mls qos

(text deleted)

interface fa0/1

description ip phone

switchport access vlan110

switchport mode access

priority queue-out

mls qos trust dscp

spanning-tree portfast

We as a staff asked for help since he wasn't contracted to program this building.

What do you think of the above config?

Thanks,

Dan

228
Views
0
Helpful
3
Replies
CreatePlease login to create content