Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

QOS issue with WAN routers.

Our wan point to point routers are not processing QOS tagging properly.   Below is a sample of my config. For some reason it seems as if qos taggin is not being passed to to the router.   Help, I need to get this going by the end of next week.

Switch1 <---> RouterA <==>RouterB<--->Switch2

Switch1 interface config

interface GigabitEthernet5/48

description DO_WAN_GW_SMS

switchport trunk allowed vlan 1,97,133,916

switchport mode trunk

auto qos voip trust

storm-control broadcast level 2.00

spanning-tree portfast

service-policy output autoqos-voip-policy

RouterA config-----------------------------------------

lass-map match-any Call-Control

match ip dscp af31

match ip dscp cs3

match ip precedence 3

class-map match-any Video

match ip dscp af41

match ip dscp cs4

match ip precedence 4

class-map match-any Voice

match ip dscp ef

match ip precedence 5

class-map match-any Routing

match ip dscp cs6

!

!

policy-map RTP-Traffic

class Voice

    priority percent 20

   compress header ip rtp

class Call-Control

    bandwidth percent 5

class Routing

    bandwidth percent 2

class class-default

    fair-queue

     random-detect

policy-map PackClassMark

class Voice

  set ip precedence 5

class Call-Control

  set ip precedence 3

class Routing

  set ip precedence 6

interface Multilink1

ip address 10.0.1.249 255.255.255.252

ip flow egress

ip pim sparse-dense-mode

ppp multilink

ppp multilink group 1

ppp multilink fragment disable

max-reserved-bandwidth 100

service-policy output RTP-Traffic

!        

!        

interface GigabitEthernet0/0.916

encapsulation dot1Q 916

ip address 10.0.1.66 255.255.255.252

ip pim sparse-dense-mode

service-policy output PackClassMark

!        

RouterA config-----------------------------------------

RouterB config-----------------------------------------

(policy and class DITO)

interface Multilink1

ip address 10.0.1.250 255.255.255.252

ip pim sparse-dense-mode

ppp multilink

ppp multilink group 1

ppp multilink fragment disable

max-reserved-bandwidth 100

service-policy output RTP-Traffic

!        

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!        

interface GigabitEthernet0/0.97

shutdown

!        

interface GigabitEthernet0/0.197

shutdown

!        

interface GigabitEthernet0/0.917

encapsulation dot1Q 917

ip address 10.0.1.70 255.255.255.252

ip pim sparse-dense-mode

service-policy output PackClassMark

!        

RouterB config-----------------------------------------

Switch2 config

interface GigabitEthernet7/48

description SMS_WAN_GW

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3,97,133,917

switchport mode trunk

switchport block multicast

qos trust cos

auto qos voip trust

storm-control broadcast level 10.00

tx-queue 3

   bandwidth percent 33

   priority high

   shape percent 33

spanning-tree portfast

service-policy output autoqos-voip-policy

----------------------------------------------------------------------------------------------------------------------

Everyone's tags (3)
379
Views
0
Helpful
0
Replies
CreatePlease to create content