Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

qos issues on 3560x - help me to solve issue

Hi all

I have been reading alot of issues around output drops on cisco 3560 switches when qos is enabled.

I just want to provide priority for my voice traffic but without dropping anything else.

the switch is not congested at all, some people say I may be having microbursts which I cannot see, as we have a 1 gig input and a 100 meg output to the wan. the wan interface is where im seeing drops.

I have configured

mls qos

mls qos trust dscp

priority queue out

here is what im getting

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 561

output queues enqueued:

queue:   threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:           0           0           0

queue 1:       58460           0           9

queue 2:           4           0           0

queue 3:         12           0           1

output queues dropped:

queue:   threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:           0           0           0

queue 1:       1088           0           0

queue 2:           0           0           0

queue 3:           0           0           0

Interface Gi0/24 TxQueue Drop Statistics

   Queue 0

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 1

     Weight 0 Frames 16232176

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 2

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 3

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 475000

   Queue 4

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 5

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 6

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

   Queue 7

     Weight 0 Frames 0

     Weight 1 Frames 0

     Weight 2 Frames 0

I havent changed any thresholds and buffers

are there any recommended settings for normal none pririty traffic so it doesnt get dropped, auto qos maybe ora good setting for the buffers / thresholds ?

help much needed

cheers

Carl

16 REPLIES
Super Bronze

Re: qos issues on 3560x - help me to solve issue

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

Ah, so your device does register drops!  Is this why you opened a new post?

In any case . . .

are there any recommended settings for normal none pririty traffic so it doesnt get dropped, auto qos maybe ora good setting for the buffers / thresholds ?

One-size often doesn't fit all.  AutoQoS may (v4 does) change queue-set 1 settings.  You might try it and see if it helps, or you might just increasing Q1 T1.  If you try the latter, I suggest you reconfigure queue-set 2 and use it for your WAN interface.  Default value should be 200, so you might try 300 or 400.  You should see a decrease in your drop rate, but all drops might not be eliminated.  Further tuning is possible.  Did you read the reference I provided in your first posting about this issue?

New Member

Re: qos issues on 3560x - help me to solve issue

here is my current setup

Queueset: 2

Queue     :       1       2       3       4

----------------------------------------------

buffers   :      25      25      25      25

threshold1:     100     200     100     100

threshold2:     100     200     100     100

reserved  :      50      50      50      50

maximum   :     400     400     400     400

which one do I need to change ?

cheers

Super Bronze

Re: qos issues on 3560x - help me to solve issue

Queueset: 2

Queue     :       1       2       3       4

----------------------------------------------

buffers   :      25      25      25      25

threshold1:     100     200     100     100

threshold2:     100     200     100     100

reserved  :      50      50      50      50

maximum   :     400     400     400     400

New Member

Re: qos issues on 3560x - help me to solve issue

Hi

that is queue 2 threshold 1,

but it looks like my traffic is dropping in queue threshold 1 ?

Super Bronze

Re: qos issues on 3560x - help me to solve issue

Yes it appears that way.

Look carefully at both show command's output - how they number queues.

New Member

Re: qos issues on 3560x - help me to solve issue

I dont understand what you are saying ?

it looks like queue 1 threshold 1 is dropping the traffic, you askign me to change queue 2 threshold 1, but the traffic will still be going to queue 1

how come you are saying to adjust queue 2 ?

Super Bronze

Re: qos issues on 3560x - help me to solve issue

Look carefully at both show command's output - how they number queues.

New Member

Re: qos issues on 3560x - help me to solve issue

Yes, its 0 1 2 3

So are you saying this maps to

1 2 3 4 ?

so queue 1 in the show command is actually 2 when you configure it ?

      

I just did the command

#mls qos queue-set output 2 threshold 1 100 300 100 100

Drop thresholds exceed the Maximum Threshold - Will use Maximum instead internally

is this correct or ?

Super Bronze

Re: qos issues on 3560x - help me to solve issue

yup

mls qos queue-set output ?

  <1-2>  queue-set id

#mls qos queue-set output 2 threshold ?

  <1-4>  enter queue id in this queue set

Super Bronze

Re: qos issues on 3560x - help me to solve issue

carl_townshend wrote:

I just did the command

#mls qos queue-set output 2 threshold 1 100 300 100 100

Drop thresholds exceed the Maximum Threshold - Will use Maximum instead internally

is this correct or ?

No, you overrode defaults for T2 and max,

try

mls qos queue-set output 2 threshold 2 300 200 50 400

Don't forget to set the WAN interface to queue set 2, too.

New Member

Re: qos issues on 3560x - help me to solve issue

is the command you put changing threshold 2 ?

I thought its threshold 1 we need to change ?

Super Bronze

Re: qos issues on 3560x - help me to solve issue

No, believe what I suggested changes T1.  You can confirm with show command after application.

New Member

Re: qos issues on 3560x - help me to solve issue

Hi I have done the settings as you said and its made no difference, still getting drops, what should I do ?

output queues enqueued:
queue:    threshold1   threshold2   threshold3
-----------------------------------------------
queue 0:           0           0           0
queue 1:      111385           0          38
queue 2:          20           0           0
queue 3:          44           0       32441

  output queues dropped:
queue:    threshold1   threshold2   threshold3
-----------------------------------------------
queue 0:           0           0           0
queue 1:          60           0           0
queue 2:           0           0           0
queue 3:           0           0           1

Super Bronze

Re: qos issues on 3560x - help me to solve issue

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

I did write earlier . . . "You should  see a decrease in your drop rate, but all drops might not be  eliminated."

Did you see a decrease in drop rate?  Your current stats only show 60 drops vs. 111,385 enqueued for Q1T1.  Cisco, I recall, says less than 1% is acceptable.

You have to realize, when you drop from gig rate to 100 Mbps, drops might be unavoidable unless you have infinitely deep queues, and if you did, you'll can obtain infinitely long queuing delays.

If you want to try to decrease the rate even more, try a value of 350 or 400, where 300 was used before.  This might bring the drop rate down a little more, but its likely not to be as dramatic.

New Member

Re: qos issues on 3560x - help me to solve issue

Hi There

After some looking into it, im now using the settings below

mls qos queue-set output 2 threshold 2 3100 3100 100 3200

mls qos queue-set output 2 buffers 10 70 10 10

srr-queue bandwidth share 20 60 10 10

queue-set 2

priority-queue out

I can still see a few dropped packets but it the application seems alot better

from the settings I have, would this affect voice at all?

and will this affect the priority queue ?

cheers

Super Bronze

Re: qos issues on 3560x - help me to solve issue

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

After some looking into it, im now using the settings below

mls qos queue-set output 2 threshold 2 3100 3100 100 3200

mls qos queue-set output 2 buffers 10 70 10 10

srr-queue bandwidth share 20 60 10 10

queue-set 2

priority-queue out

I can still see a few dropped packets but it the application seems alot better

from the settings I have, would this affect voice at all?

and will this affect the priority queue ?

It (still) could (I see you shifted 10% of buffers from Q2 to Q1, compared to your other posting).  See my response in your other posting, https://supportforums.cisco.com/message/3999090#3999090 why it could.

269
Views
0
Helpful
16
Replies
CreatePlease to create content