Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS marking on vlan - cat3750

I was wondering if it is possible to apply a class base policing on a vlan rather than a port in Catalyst 3750-24T (IP Base) for marking rather than port.

the switch is operating in layer 2 mode (only layer 3 address is for management).

Additionally, i made a simple test policy map for marking dns and ntp traffic with Cos4, but it doesn't seem to work. I have enabled QoS globally. See below......

Is it configuration mistake, does it need a restart after enabling qos or is it a License issue (because i use ip-base)

!

mls qos

!
class-map match-all Class-dns-traffic
  match access-group name dns-traffic

class-map match-all Class-ntp-traffic
  match access-group name ntp-traffic
!


!        
policy-map Test-Policy
  class Class-dns-traffic
   set dscp cs4
  class Class-ntp-traffic
   set dscp cs4
  class class-default
   set dscp default

!

ip access-list extended dns-traffic
permit udp any any eq domain

!

ip access-list extended ntp-traffic
permit udp any any eq ntp

!

interface range GigabitEthernet1/0/1 - 24

service-policy input Test-Policy

3 REPLIES
Hall of Fame Super Blue

Re: QoS marking on vlan - cat3750

pavlosd wrote:

I was wondering if it is possible to apply a class base policing on a vlan rather than a port in Catalyst 3750-24T (IP Base) for marking rather than port.

the switch is operating in layer 2 mode (only layer 3 address is for management).

Additionally, i made a simple test policy map for marking dns and ntp traffic with Cos4, but it doesn't seem to work. I have enabled QoS globally. See below......

Is it configuration mistake, does it need a restart after enabling qos or is it a License issue (because i use ip-base)

!

mls qos

!
class-map match-all Class-dns-traffic
  match access-group name dns-traffic

class-map match-all Class-ntp-traffic
  match access-group name ntp-traffic
!


!        
policy-map Test-Policy
  class Class-dns-traffic
   set dscp cs4
  class Class-ntp-traffic
   set dscp cs4
  class class-default
   set dscp default

!

ip access-list extended dns-traffic
permit udp any any eq domain

!

ip access-list extended ntp-traffic
permit udp any any eq ntp

!

interface range GigabitEthernet1/0/1 - 24

service-policy input Test-Policy

Yes it is possible. Have a look at the configuration guide which gives an example of exactly how to do that -

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_52_se/configuration/guide/swqos.html#wp1767120

Jon

New Member

Re: QoS marking on vlan - cat3750

I was hoping for an actual example, not a documentation example.

Another thing is that the reason i couldn't get the qos to work in 3750 is that I found out through other forums that the command

"show policy-map interface" is not working (BUG???) and should be replaced with "sh mls qos interface statistics" instead.

So it was a bit of missleading....

For the VLAN based configuration, i followed a nice example....

http://blog.ine.com/tag/vlan-based/

Hall of Fame Super Blue

Re: QoS marking on vlan - cat3750

I was hoping for an actual example, not a documentation example.

Oh i see. You just wanted to be told how to do it, you didn't actually want to have to do anything. I gave a link to the dccumentation because you asked if it could be done and i thought that by providing you with the link you would learn about vlan based QOS.

Jon

445
Views
7
Helpful
3
Replies
CreatePlease login to create content