Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS: Match VLAN feature

Hi Sir,

I'm configuring a Catalyst 3550 to meet the following requirement:

*** VLAN 12 should allow no more than 2Mb total throughput ***

I came across the following solution:

!

mls qos

mls qos aggregate-policer 2MB 2000000 375000 exceed-action drop

!

class-map match-all VL12

match vlan 12

match class-map class-default

!

policy-map MyPolice

class VL12

police aggregate 2MB

!

interface FastEthernet0/1

switchport mode access

switchport access vlan 12

service-policy input MyPolice

!

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

service-policy input MyPolice

!

Questions:

(1) Is the command "match class-map class-default" necessary? I think the command "match vlan 12" alone suffices.

(2) I understand that the Match VLAN feature allows us to classify network traffic on the basis of the Layer 2 VLAN identification number. Does it take effect when applied to access links, like the example above? Or should it be applied to trunk links carrying that VLAN to be matched?

I'd configure it simply as follows:

!

policy-map MyPolice

class class-default

police aggregate 2MB

!

interface FastEthernet0/1

switchport mode access

switchport access vlan 12

service-policy input MyPolice

!

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

service-policy input MyPolice

!

Please advise.

Thank you.

B.Rgds,

Lim TS

2 REPLIES
Anonymous
N/A

Re: QoS: Match VLAN feature

class-map class-map-name command Creates a class map using the name you enter for the traffic class and enters class-map configuration mode. But match vlan {vlan-id | vlan-id1-vlan-id2} command defines one or more VLANs to use as match criteria against incoming packets to classify traffic.

New Member

Re: QoS: Match VLAN feature

Lim,

I have the same doubt. Could you found the answer?

I have the same requirement as you (VLAN XX should allow no more than 10Mb total throughput).

Thanks and regards. Martín.

172
Views
0
Helpful
2
Replies
CreatePlease to create content