Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

QoS - Matched packets not marked on 4507

Hi,

I am facing some issues in implementing QoS on a 4507 switch (IOS 12.1).I want to mark traffic sent by all CCTV's, ACS/INTERCOM and BMS devices to respective servers from 54 floors.For that i created access-lists,class-maps and policy maps.Then i applied the policy maps to the respective vlan interfaces.The issue is that, though i can see the hit count of the access-lists incresing and packets matched increasing, the packets MARKED remain at 0.I want these packets to be marked with dscp 16.But it seems it is not happening. I am copying some of the configs. Please advice

Thanks and Regards,

Sonu

class-map match-all TRUST-ACS-INTERCOM

match ip dscp cs2

class-map match-all CATCH-ACS-INTERCOM

match access-group name ACS-INTERCOM-TRAFFIC

class-map match-all TRUST-BMS

match ip dscp cs2

class-map match-all CATCH-BMS

match access-group name BMS-TRAFFIC

class-map match-all CATCH-CCTV

match access-group name CCTV-TRAFFIC

class-map match-all TRUST-CCTV

match ip dscp cs2

!

!

policy-map ACT-ACS-INTERCOM

class TRUST-ACS-INTERCOM

trust dscp

policy-map ACT-BMS

class TRUST-BMS

trust dscp

policy-map MARK-CCTV

class CATCH-CCTV

set dscp cs2

policy-map MARK-ACS-INTERCOM

class CATCH-ACS-INTERCOM

set dscp cs2

policy-map MARK-BMS

class CATCH-BMS

set dscp cs2

policy-map ACT-CCTV

class TRUST-CCTV

trust dscp

ip access-list extended ACS-INTERCOM-TRAFFIC

permit ip 172.16.8.0 0.0.7.255 172.16.32.0 0.0.7.255

ip access-list extended BMS-TRAFFIC

permit ip 172.16.88.0 0.0.7.255 172.16.112.0 0.0.7.255

ip access-list extended CCTV-TRAFFIC

permit ip 172.16.48.0 0.0.7.255 172.16.72.0 0.0.7.255

interface Vlan204

no ip address

service-policy input MARK-BMS

service-policy output ACT-BMS

!

interface Vlan205

no ip address

service-policy input MARK-ACS-INTERCOM

service-policy output ACT-ACS-INTERCOM

!

interface Vlan206

no ip address

service-policy input MARK-CCTV

service-policy output ACT-CCTV

show policy-map interface vlan 206

----------------------------------

Service-policy input: MARK-CCTV

Class-map: CATCH-CCTV (match-all)

5802754 packets

Match: access-group name CCTV-TRAFFIC

QoS Set

ip dscp cs2

Packets marked 0

Class-map: class-default (match-any)

12922590 packets

Match: any

Service-policy output: ACT-CCTV

Class-map: TRUST-CCTV (match-all)

0 packets

Match: ip dscp cs2

Class-map: class-default (match-any)

12922590 packets

Match: any

1 REPLY
Silver

Re: QoS - Matched packets not marked on 4507

Below is link to Provide with sample config and Reference documents and design guides on implementing QoS on 4507's,

Configuring QoS on the Catalyst 4000 (IOS):

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_11/config/qos.htm

409
Views
0
Helpful
1
Replies
CreatePlease to create content