Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Qos Newbie

Hi,

The company I work have finally decided to enter the 21st century and invest in a new telephone system (Interactive Intelligence) to replace the legacy system which has served us well for the past 10 years. The project has only just started and involves upgrading sections of CAT3 cabling to CAT6, replacing Cisco 3550 switches in one area of the building with Cisco 4507 switches and upgrading our Core switches with Cisco Nexus 7010's.

The area that concerns me most is enabling the network for qos as I have very little experience with it. At the moment Im trying to read as much documentation as I can on QOS to bring myself up to speed.

The access layer switches will consist of a mixture of Cisco 3750 & 4507 switches connected to Cisco Nexus 7010 switches which will form a collapsed aggregation & core layer.

Basically I'm after any advice on how I should approach this daunting task of making sure the network will support VOIP.

Any advice is very much appreciated.

Many Thanks

Darren

6 REPLIES
Green

Qos Newbie

Hi,

QOS is a big subject nowadays.

This SRND doc seems to be popular

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSCampus_40.html

HTH

Alex

Regards, Alex. Please rate useful posts.
Community Member

Qos Newbie

Do you want to know about QoS or VoIP?

Cisco Employee

Qos Newbie

You need to start with SRND link to which posted by Alex, understand needs of voice and any other priority traffic in the network and then read QoS guide for used platforms:

Here is Nexus 7000 QoS description and config guide:

http://www.cloudcentrics.com/?p=784

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/qos/configuration/guide/nx-os_qos_book.html

HTH,

Alex

Community Member

Qos Newbie

Hi,

Think I need to understand both Qos and voip but primarily qos. We do have  a subsiduary company which already uses VOIP. I've looked at some of the config so just trying to get my head around it.

interface GigabitEthernet1/10

service-policy input Input-Dscp-Policy
service-policy output Output-Policy

class-map match-all Nortel-Voice-QosGroupEF

  match qos-group 46

class-map match-all Nortel-Control-Dscp

match dscp cs5

class-map match-all Nortel-Voice-Dscp

match dscp ef match

policy-map Input-Dscp-Policy

class Nortel-Voice-Dscp

   set qos-group 46

   set cos 5

class Nortel-Control-Dscp

   set qos-group 24

policy-map Output-Policy
class Nortel-Voice-QosGroupEF
    priority
    police cir percent 33
class Nortel-Control-QosGroup24
    bandwidth remaining percent 5
class class-default
    dbl

If my understanding is correct on the input side the RTP traffic is marked by the phone with a dscp value of ef, the policy map then sets the dscp value to 46 and the cos value to 5. The signaling traffic is marked with dscp value of 24. On the output side the policy map matches traffic with dscp value of 46 and places this traffic in the priority queue which is guranteed 33% of the bandwidth. If the RTP traffic exceeds 33% then it is dropped. The signaling traffic is allocated 5% of the remaining traffic using CBWF. All other traffic uses the default class.

Green

Qos Newbie

Hi,

It is always a good idea to ask the Nortel/Avaya engineers to set the DSCP for signalling to 24 when their kit is connecting to a CISCO LAN/WAN set up.

Thankfully Nortel/Avaya use dscp 46(EF) for the VOICE traffic.

You can usually use a config like this on a 3750/3560

!

interface FastEthernet1/0/25

description *** Nortel  IP Phone & PC Port ***

switchport access vlan 5

switchport mode access

switchport voice vlan 705

srr-queue bandwidth share 1 70 25 5

priority-queue out

mls qos trust dscp

spanning-tree portfast

!

This moves the trust boundary to phone trusdting its DSCP values

HTH

Alex

Regards, Alex. Please rate useful posts.
Community Member

Qos Newbie

Just asking..if our local network using fast ethernet or gigabit to the desktop, do we need to setup QoS for the voice?

IP phone marking the packets with dscp EF. Is it different with different brand and model for IP phone? How to check the dscp EF for IP Phone? I'm using Aastra IP Phone.

Please advice . thanks

737
Views
0
Helpful
6
Replies
CreatePlease to create content