Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS of Natted Hosts

I can not configure my 3600 to QoS my natted hosts in both directions. It can only limit the download bandwidth but not upload bandwidth.

Details for my config:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname pmsi_qos

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

username admin password xxx

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.10.1

!

ip dhcp pool 0

network 192.168.10.0 255.255.255.240

dns-server 203.189.XX.PO

default-router 192.168.10.1

lease infinite

!

!

no ip domain lookup

ip name-server 203.189.XX.XX

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

!

class-map match-any NATTED-HOSTS-IN

match access-group name NATTED-HOSTS-IN

class-map match-any NATTED-HOSTS

match access-group name NATTED-HOSTS

!

!

policy-map To-Alpha

class NATTED-HOSTS

shape average 64000

class class-default

shape average 8000

policy-map To-PMSILan

class NATTED-HOSTS-IN

shape average 64000

class class-default

shape average 8000

!

!

!

interface FastEthernet0

description ***PMSI-LAN side***

ip address 192.168.10.1 255.255.255.240 secondary

ip address 203.189.XX.YY 255.255.255.224

ip nat inside

service-policy output To-PMSILan

speed auto

!

interface FastEthernet1

shutdown

!

interface Serial0

description *** To Alpha Serial 2/1 ***

bandwidth 2000000

ip address 203.189.XX.YZ 255.255.255.252

ip nat outside

service-policy output To-Alpha

load-interval 30

clockrate 2000000

!

ip nat inside source list 7 interface Serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 203.189.XX.XZ

no ip http server

!

!

ip access-list extended NATTED-HOSTS

permit ip host 203.189.11.98 any

ip access-list extended NATTED-HOSTS-IN

permit ip any 192.168.10.0 0.0.0.15

access-list 7 permit 192.168.10.0 0.0.0.15

access-list 99 permit 203.189.XX.WZ

access-list 99 permit 203.189.XX.AZ

access-list 99 deny any

snmp-server community joshua RO 99

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server host 203.189.XX.WZ jose

snmp-server host 203.189.XX.AZ jose

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password 7 01190501

login local

!

!

end

2 REPLIES

Re: QoS of Natted Hosts

HI, [Pls Rate if HELPS]

If my understanding is not wrong,

To apply the QOS on the Interface connected to the Service Provider for limiting the Upload Bandwidth, you need to request the Service Provider to apply the QOS in their interface.

Neverthless, you can limit the Download Bandwidth at Customer Premessis Equipment itself.

Pls Rate if HELPS

Best Regards,

Guru Prasad R

New Member

Re: QoS of Natted Hosts

Let me reiterate the problem... My problem is not about the service provider, it is about making the natted hosts bandwidth to be shaped (limited) download and upload. I can limit the download bandwidth to the interface because it can still recognize the private IP address, for the upload you can only limit the bandwidth of the whole subnet because it is NATted (overload) meaning the public ip add can only be limited.

How can I limit the upload bandwidth of my NATted hosts?? Have you guys already tried this one?

113
Views
0
Helpful
2
Replies
CreatePlease to create content