Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS on 2960

Hello everybody,

I need a little help to set up my QoS on two 2960, can you help me ?

--------------------      -------              -------            ------------

PBX Asterisk |----|2960-1 |------|2960-2 |-----|Voip client2|

--------------------      -------             -------             ------------

--------------              |

|Voip Client1|----------

--------------

VLAN voice :

@IP PBX : 10.1.1.1

@IP CLient 1 : 10.1.1.2

@IP Client 2 : 10.1.1.3

VLAN data :

Other machine with @ip 10.2.2.0

The PBX is connected to fa0/1

The Voip Client1 is connected to fa0/2

Trunk between 2960 is on interface giga 0/1 for both - speed of 10 mbits/s for both

The Voip Client2 is connected to fa0/1

I want to prioritize traffic between the two Voip Client, let's say 30% of the bandwith on the trunk.

The rest of the traffic will be send in best effort

I've read a lot of stuff but I'm kind of lost now.

That could be done like that ?

On the 2960-1 :

ip access-list extended MATCH_Voice

permit ip 10.0.1.0 0.0.0.255 any

ip access-list extended MATCH_Data

permit ip 10.2.2.0 0.0.0.255 any

class-map match-all Voice

match access-group name MATCH_Voice

class-map match-all Data

match access-group name MATCH_Data

policy-map input

class Voice

set precedence 5

class Data

set precedence 0

This will be this configuration for all input interface right ?

For the Output part I'm lost, what do I have to do ?

And for the 2960-2 do I have to put the same configuration ?

If you have any other idea to help me, just go for it.

Thank you for your time.

Regards,

Jonathan!;

Everyone's tags (2)
5 REPLIES
Silver

Re: QoS on 2960

Have you considered Autoqos? it will configure everthing for you. You can play with the percentages based on your requirements.

commands to configure Autoqos

Go to the interface and configure the below commands

mls qos trust dscp (for layer 3 links and access ports)

mls qos trust cos (for trunk ports and voice vlan ports- your case)

auto qos voip trust

The above commands will configure everyting for you and then you can go to the interface and chage the percetage values.

If you don't want to take that route, have a look at the below 2 links,

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

https://supportforums.cisco.com/message/3636022#3636022

Small changes in your config

policy-map input

class Voice

set precedence 5 (precedence is a layer 3 atribute and its legacy)

set cos 5

class Data

set precedence 0

set cos 0

Siddhartha
New Member

Re: QoS on 2960

Hi,

I think i'm going to study what Auto Qos is doing, for now.

If you have some link about this, that will be nice of you.

Just for the command set cos 0 or 5

I don't have any set cos in the policy map command on my 2960, that's why I used precedence

(In my 3550, I have "set cos" though)

Is this normal ? my 2960 is running ios 15.0

Gold

Re: QoS on 2960

Hey there...

you could use this for the out put part:

!

!

class-map match-all VOICE

  match dscp ef 

policy-map VOICE_OUT

  class VOICE

    priority percent 30

    police percent (%)   OR   police rate (kbps) 

    exceed-action drop 

! police and exceed-action are optional; so to make sure the class VOICE doesnt eat up all ur BW n starve other !classes since it's the priority class.

class class-default

    fair-queue

interface X

service-policy out VOICE_OUT

!

!

if it helped you, pls rate it ;-)

Hope it Helps!

Soroush.
Silver

Re: QoS on 2960

Below is the link for Autoqos

http://www.cisco.com/en/US/customer/tech/tk543/tk759/technologies_white_paper09186a00801348bc.shtml

All autoqos does is to configure the steps in the below document automatically.

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

The youtube video explains about configuring QoS in the switches in a very detailed manner

http://www.youtube.com/watch?v=IA4iOrn2eiU

"Is this normal ? my 2960 is running ios 15.0"

I am not sure about that, have to check

Siddhartha
New Member

Re: QoS on 2960

Wow, thank you.

I will read all of it. It seems to be very interesting stuff

Thanks for the help guys !

626
Views
19
Helpful
5
Replies
CreatePlease login to create content