Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

QOS on 3560

Hi all

I have VLAN based policy as per below.

sh mls qos inte XX stati shows correct marking, however show policy map vlan does not show any traffic clocking up.

I have applied similar strategy on 7600 and can see traffic rate on policy map.

mls qos

!

access-list 101 permit ip any any

!

class-map match-all MNGT

match access-group 108

!

policy-map 671-man

class vlan104

set dscp cs3

!

interface Vlan2990

service-policy input MVB-MNGT

!

interface GigabitEthernet0/2

mls qos vlan-based

no cdp enable

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: QOS on 3560

This is a limitation with the hardware on the 3560/3750 platforms. At this time we wont show # of policy-map matches in 'show policy-map interface'.

I dont believe there is a plan to fix this, so the best idea is using the 'show mls qos interface statistics' to make sure the policy is working.

3 REPLIES
Silver

Re: QOS on 3560

please post more of the config. You have ACL 101, that is not refered to in any displayed class-map.

Also you have class vlan104 but there is no "class-map vlan104" configuration.

There is class-map MNGT configuration, but no policy-map refers to it.

Also, MNGT class-map refers to ACL 108, that is not displayed in config.

Re: QOS on 3560

apologies, I quickly coped and pasted to highlight the method used and I can conform my marking is working as it should.

here is the correct conf:

mls qos

!

access-list 108 permit ip any any

!

class-map match-all MNGT

match access-group 108

policy-map MVB-MNGT

class MNGT

set dscp cs6

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1520-1526,2990

switchport mode trunk

mls qos vlan-based

!

!

interface Vlan2990

service-policy input MVB-MNGT

Silver

Re: QOS on 3560

This is a limitation with the hardware on the 3560/3750 platforms. At this time we wont show # of policy-map matches in 'show policy-map interface'.

I dont believe there is a plan to fix this, so the best idea is using the 'show mls qos interface statistics' to make sure the policy is working.

371
Views
0
Helpful
3
Replies