Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS on 3750G

Dear All,

I configured QoS on 3750G switch to give priority for the Video, IPTV and Voice traffic going to another site.

The physical WAN link is 1G, but the service provides is only providing 400Mbps.

//Match voice traffic and VOIP traffic coming from the LAN1

access-list 116 permit ip any any dscp 46

access-list 117 permit ip 192.168.1. 0.0.0.255 any

class-map LAN1_VOIP

match access-group 116

class-map IPTV

match access-group 117

class-map VIDEO

match access-group 117

//set new DSCPs (EF for voice and dscp41 for IPTV, AF31 for all other traffic)

policy-map LAN1_INPUT

class LAN1_VOIP

  set dscp 46

class IPTV

  set dscp 41

class class-defaut

  set dscp af31

policy-map VIDEO_INPUT

class VIDEO

  set dscp 41

interface g1/0/14

description FROM_LAN1

service policy input LAN1_INPUT

interface g1/0/8

service policy input VIDEO_INPUT

-->So now voice and video traffic will be mapped to Q1, all other traffic will be mapped to Q3

interface GigabitEthernet1/0/28

description TO_WAN

srr-queue bandwidth share 1 80 10 10

srr-queue bandwidth shape  5  0  0  0

srr-queue bandwidth limit 40

priority-queue out

mls qos

------------------------------------------------------------------

So the Queuing mapping will be as follow:

Q1: is for Voice, Video and IPTV (the actual traffic is around 150Mbps

Q2: currently no traffic in this queue but will be used for LAN2

Q3: for other traffic coming from LAN1

Q4: currenty no traffic in this queue but will be used for LAN2

So Q2,Q3 and Q4 should share the remaining bandwidth .

after i applied the above configuration the voice and video traffic (around 150M) was very good by monitoring it in the another site, but the file transfer (Q3) was slow (it takes only around 130M of the remaining traffic  although I have available bandwidth), so do i need to add another configurations to solve the problem.

Thanks and regards

6 REPLIES
Hall of Fame Super Silver

Re: QoS on 3750G

Hello Justanas1,

your configuration looks like correct and interesting specially this command:

srr-queue bandwidth limit 40

Use the srr-queue bandwidth limit interface configuration command on the switch stack or on a standalone switch to limit the maximum output on a port. Use the no form of this command to return to the default setting.

Usage Guidelines

If you configure this command to 80 percent, the port is idle 20 percent of the time. The line rate drops to 80 percent of the connected speed. These values are not exact because the hardware adjusts the line rate in increments of six.

this may mean that 40 is seen as 36.

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_44_se/command/reference/cli3.html#wp1947391

The priority queue is served first that is the objective of the priority queue.

So unfortunately on the other queues you get what is left by the priority queue.

A file transfer is an FTP transfer that is TCP based so packets are not simply sent they are sent within the TCP window of the sender that acts based on acks received from the receiver.

Probably this is the best you can get with this multilayer switch that has no outbound queueing and no hierachical QoS like a router.

Hope to help

Giuseppe

New Member

Re: QoS on 3750G

Hi Giuseppe,

Thank you for your reply.

before i applied the QoS, the FTP was fast and arrived arround 300M, so i think it is not windowing problem.

Regards,

Anas

Re: QoS on 3750G

hi Anas

as Giuseppe mentioned above, when you enable the priority queue in the switch this queue will be serviced first and even more it will not be governed by the shape limit !!! that's why you need to take this into your considerations when you enable it

good lcuk

if helpful Rate

New Member

Re: QoS on 3750G

hello,

I monitored the link before and after enabeling the QoS,

before i enabled the QoS, the Video, IPTV and Voice were utilizing arround 120M and i started FTP session, the one session tooke arround 200M.

But after i enabled the QoS, the Video, IPTV and Voice utilized arround 120M then i tested FTP session it utilized only 50M although the link has available BW and i checked that using solarwinds.

Anas

Re: QoS on 3750G

just make sure from the dscp to cos maping as you have the set command used dscp and the queuing in the switch consider cos

set dscp >> local dscp- cos map>> cos queues

New Member

Re: QoS on 3750G

Hi Marwan,

Yes i set the DSCP and used the default dscp to queue mapping, i believe the dscp to queue mapping is used not the cos to queue mapping as the dscp mapping override the cos to queue mapping,

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

Anas

818
Views
0
Helpful
6
Replies