Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS on 6500 with IOS 15

Hopeing some one can help me here.

I set up queing on a port on the 6500 using the followign config

switchport

switchport access vlan 1020

speed 100

duplex full

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50 60 60 70 70

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80 90 90 100 100

wrr-queue cos-map 2 1 1 2

wrr-queue cos-map 3 5 3 4

wrr-queue cos-map 3 7 6 7

rcv-queue cos-map 1 2 1

rcv-queue cos-map 1 3 2

rcv-queue cos-map 1 4 3

rcv-queue cos-map 1 5 4

rcv-queue cos-map 1 6 5

rcv-queue cos-map 1 7 6

rcv-queue cos-map 1 8 7

auto qos voip trust

spanning-tree portfast edge

end

however when I do

#show queueing int g1/2/41

I see

Interface GigabitEthernet1/2/41 queueing strategy:  Weighted Round-Robin

  Port QoS is disabled globally

  Queueing on Gi1/2/41: Tx Disabled Rx Disabled

Trust boundary disabled

..

..

..

..

So how do I enable port QoS and queueing? I thought these were all enabled by default or would be enabled by the "auto qos" command?

I should mention that on some ports I am using service-policy to match and set DSCP vlaues. should I really in IOS 15 use policy based QOS for queueing as well, as detailed in this document.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SY/configuration/guide/qos_policy_based_queueing.pdf

There does not seem to be many examples of QOS configuration for IOS15 around.

Thank you

  • LAN Switching and Routing
12 REPLIES
New Member

QOS on 6500 with IOS 15

mls qos command will enable the hardware QoS that you are using

cheers

New Member

Re: QOS on 6500 with IOS 15

IOS 15 so platfrom QOS does not exist.

i worked out that

"platform qos queuing-only" will enable it, however that prevents policy for marking and policing

so the way to do it was remove the

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50 60 60 70 70

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80 90 90 100 100

wrr-queue cos-map 2 1 1 2

wrr-queue cos-map 3 5 3 4

wrr-queue cos-map 3 7 6 7

rcv-queue cos-map 1 2 1

rcv-queue cos-map 1 3 2

rcv-queue cos-map 1 4 3

rcv-queue cos-map 1 5 4

rcv-queue cos-map 1 6 5

rcv-queue cos-map 1 7 6

rcv-queue cos-map 1 8 7

auto qos voip trust

And instead use a

policy-map type lan-queuing to set up the queues this then shows as

ASH_6506#sh queueing int g1/2/41

Interface GigabitEthernet1/2/41 queueing strategy:  Weighted Round-Robin

  Port QoS is disabled globally

  Queueing on Gi1/2/41: Tx Enabled Rx Disabled

I have only applied a service-policy on the outbound direction so only enabled TX

Full cisco documatation is here

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.0SY/configuration/guide/qos_policy_based_queueing.html

If you enable "platform qos queuing-only" as auto qos had done then it shows as

Port QoS is Enababled globally

  Queueing on Gi1/2/41: Tx Enabled Rx Enababled

but you lose the ability to apply service-policies to mark or police traffic if you do.

All the docs for IOS 15, suggest you use policy and talk about the old interface queuing commands as legecy, so I think I am happy to learn the moden way

cheers for the reply though

New Member

QOS on 6500 with IOS 15

I am still not clear on the QoS configuration for the Sup2T or the modules on the 6509-E. We have a 6509-E with sup2t and two X6704 modules for the 10G, used on UCS uplinks, 3 of the X6848 for other connections.

I created the input and output policies of lan-queueing type and applied to the interfaces. With the lan-queueing type policies, I can use the priority command. So I have traffic of dscp ef or cos 5 prioritized and other classes in the remaining queues. However, I can classify or mark the traffic with the lan-queuing class-map. We are not using Cisco VOIP solution. So how do I classify a subnet to be set with cos 5 or dscp ef and then priority that subnet?

Also, I need to make sure all the voip traffic is leaving the switch with ef for dscp value, video with af41 for dscp, and two more classes of af31 and af21.

Please help.

Thanks

VIP Purple

Re: QOS on 6500 with IOS 15

Hi Nguyen,

Each line card is having their own queuing capability, first of all you need to aware of that

WS-X6704-10GE (Ingress 8q8t, Egress 1p7q8t)

WS-X6848-TX-2T (Ingress 2q8t, Egress 1p3q8t)

VS-S2T-10G-XL ( Ingress 2q4t, Egress 1p3q4t) when Gig ports enabled.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.1SY/config_guide/sup2T/qos_policy_based_queueing.html#wp1005968

Therefore you need to have custom policy maps for each line card or have a generic policy map commonly applicable to all of them. If you want to use subnet based classification then you have to use "match access-group x" with classification ACL instead of DSCP or CoS based marking under class map configuration. In below example, I am assuming traffic is classified at the acces layer switch (since it is from a distribution switch)

Here is 1G-Ingress policy-map example with 2q4t & 1G-Egress policy-map for 1p3q4t which can be applicable to above scenario (1G ports).

platform qos queueing-only

!

class-map type lan-queuing match-any REALTIME-TRAFFIC

match cos 4 5

!

class-map type lan-queuing match-any GUARANTEEDTRAFFIC

match cos 1 2 3 6 7

!

policy-map type lan-queuing 1G-Egress

class REALTIME-TRAFFIC

priority

queue-limit multiple-type-based

queue-limit cos values 4 5 percent 100


class GUARANTEED-TRAFFIC

bandwidth remaining percent 50

queue-limit multiple-type-based

queue-limit cos values 1 percent 60

queue-limit cos values 2 percent 70

queue-limit cos values 3 percent 80

queue-limit cos values 6 7 percent 100


class class-default

queue-limit cos values 0 percent 100

!

policy-map type lan-queuing 1G-Ingress

class REALTIME-TRAFFIC

bandwidth percent 30

queue-limit multiple-type-based

queue-limit cos values 4 5 percent 100

!

class class-default

queue-limit multiple-type-based

queue-limit cos values 0 1 percent 60

queue-limit cos values 2 percent 70

queue-limit cos values 3 percent 80

queue-limit cos values 6 7 percent 100

!

interface GigabitEthernet2/1

service-policy type lan-queuing input 1G-Ingress

service-policy type lan-queuing output 1G-Egress

Here is another example for 10G port egress/ingress based on the 1p7q4t model.

class-map type lan-queuing match-any NETWORK-CONTROL

match dscp 48 56

class-map type lan-queuing match-any VOIP-TRAFFIC

match cos 5

match dscp 46

class-map type lan-queuing match-any MULTIMEDIATRAFFIC

match cos 4

match dscp 34

class-map type lan-queuing match-any CRITICAL-DATA

match dscp 18

class-map type lan-queuing match-any BULK-DATA

match dscp 16

class-map type lan-queuing match-any SCAVENGER

match dscp 8

!

policy-map type lan-queuing 6816-10G

class VOIP-TRAFFIC

priority

class NETWORK-CONTROL

bandwidth remaining percent 10

class MULTIMEDIA-TRAFFIC

bandwidth remaining percent 20

class CRITICAL-DATA

bandwidth remaining percent 20

class BULK-DATA

bandwidth remaining percent 40

class SCAVENGER

bandwidth remaining percent 5

queue-limit multiple-type-based

queue-limit dscp cs1 percent 100

class class-default

queue-limit multiple-type-based

queue-limit cos values 0 1 2 3 percent 70

queue-limit cos values 6 7 percent 100

!

interface TenGigabitEthernet4/1

service-policy type lan-queuing input 6816-10G

service-policy type lan-queuing output 6816-10G

You may need to modify the mapping table depend on the way you do the classification. In my case I have used like this

table-map cos-discard-class-map

map from 0 to 0

map from 1 to 8

map from 2 to 16

map from 3 to 18

map from 4 to 34

map from 5 to 46

map from 6 to 48

map from 7 to 56

!

table-map discard-class-cos-map

map from 0 to 0

map from 8 to 1

map from 16 to 2

map from 18 to 3

map from 34 to 4

map from 46 to 5

map from 48 to 6

map from 56 to 7

Hope this help you to comeup with a suitable QoS scheme for your environment.

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Re: QOS on 6500 with IOS 15

Thanks for a detailed configuration example.

I have configured the policy maps and class maps for lan-queueing type, which are shown in your examples above. The match access-group name ACL_Name is not an option for the class-map type lan-queueing class.

So I am still struggling with classifying traffic based on subnets, which is Layer 3 and then applying Layer 2 QoS for prioritization and queueing.

Please advise.

Thanks

VIP Purple

Re: QOS on 6500 with IOS 15

If that is the case your options are limited.

In this Sup2T architecture it is assumed  your traffic is pre-classified.(typical enterprise network where access switches are there before traffic hitting Sup2T or distribution/core)

I understand in your case it is data centre environment where you want to classify traffic at this swich level.

Rasika

New Member

Re: QOS on 6500 with IOS 15

What I do is mark using an inbound policy map on other interfaces and queue on the outbound. Infact you can't do MQC outbound on the ethernet line cards on the sup2T so your only option is to either classify and mark incomming to physical intefaces or on vlans.

New Member

Re: QOS on 6500 with IOS 15

Would you give me some examples on how to mark/classify the traffic based on subnets for the incoming interfaces on the other linecards? Then prioritize them on the uplink interface to the WAN?

Thanks

New Member

Re: QOS on 6500 with IOS 15

Yes, in our environment, this switch is used as access layer switch as well, for some devices but most of the IP Phones are on another PoE switch, which we can't classify or mark so we have to do that marking/classifying on the incoming ports from that PoE switch.

Would you let me know how I can mark the traffic based on subnets and use Layer 2 policies to put them into respective queues?

Thanks

1434
Views
14
Helpful
12
Replies
This widget could not be displayed.