Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS on Cisco 7604

Looking to classify/mark with MQC/IP NBAR on ingress and CBWFQ on egress with following configuration, appreciate any feedback or input:

Mls qos

Classification/Marking

class-map match-all WAN-Business-3-Mark

match protocol citrix

!

class-map match-all WAN-Premium-2-Mark

match protocol rtp video

!

class-map match-all WAN-Premium-1-Mark

match protocol rtp audio

!

class-map match-all WAN-Best-Effort-Mark

match access-group name default-0

policy-map QoS-Mark

class WAN-Premium-1-Mark

  set ip dscp ef

class WAN-Premium-2-Mark

  set ip dscp af41

class WAN-Business-3-Mark

  set ip dscp af11

class WAN-Best-Effort-Mark

  set ip dscp default

!

ip access-list extended default-0

permit ip any any

interface Vlanx

description x

ip vrf forwarding x

ip address x.x.x.x x.x.x.x

ip nbar protocol-discovery

service-policy input QoS-Mark

CBWFQ

class-map match-all WAN-Premium-1-(Voice)

match ip dscp ef

!

class-map match-all WAN-Premium-2-(Video)

match ip dscp af41

!

class-map match-all WAN-Business-3-(Citrix)

match ip dscp af11

!

class-map match-all WAN-Best-Effort-(Default)

match ip dscp 0

!

!

policy-map WAN-QoS

class WAN-Premium-1-(Voice)

  priority x

class WAN-Premium-2-(Video)

  bandwidth x

class WAN-Business-3-(Citrix)

  bandwidth x

class WAN-Best-Effort-(Default)

fair-queue

interface Vlanx

description x

ip vrf forwarding x

ip address x.x.x.x x.x.x.x

service-policy output WAN-QoS

Everyone's tags (4)
3 REPLIES
Cisco Employee

QOS on Cisco 7604

Hello,

The usage of QoS on the 7600 and the 6500 to a huge extent on the line cards being used.

Could you give me the output of show module and show version that is currently in use on the 7600?

7600 follows Catalyst QoS, and is implemented in hardware, which means most of the options that you have used here in the policy maps are not supported since they are part of the MQC QoS schema.

For further information refer to this link:

http://www.cisco.com/en/US/customer/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/qos.html#wp1481044

Implementatio of QoS also depends on the kind of line cards being used. ES+ line cards do support full MQC QoS.

HTH

Pronoy

New Member

QOS on Cisco 7604

Thanks for feedback Pronoy,

info as requested:

Mod Ports Card Type                              Model              --- ----- -------------------------------------- ------------------ -----------

  1    2  Supervisor Engine 720 (Active)         WS-SUP720-3B      

  2   24  CEF720 24 port 1000mb SFP              WS-X6724-SFP      

  3   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX    

  4    0  4-subslot SPA Interface Processor-400  7600-SIP-400

Cisco IOS Software, c7600s72033_rp Software (c7600s72033_rp-ADVENTERPRISEK9-M), Version 12.2(33)SRD4, RELEA                                          SE SOFTWARE (fc2)

ROM: System Bootstrap, Version 12.2(17r)S4, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, c7600s72033_rp Software (c7600s72033_rp-ADVENTERPRISEK9-M), Version 12.2(33)SRD4, RELEASE SOFTWARE (fc2)

New Member

QOS on Cisco 7604

looking at the SIP-400 capability, following should be possible supporting MQC marking and CBWFQ

Cisco 7600 SIP-400 Packet Marking

IP precedence (set ip precedence command)—Input and output

DSCP (set dscp command)—Input and output

Class-based marking

DE to EXP marking/ToS/DSCP

CLP to EXP marking/ToS/DSCP

Ethernet 802.1q priority bits to EXP marking (EoMPLS)

Cisco 7600 SIP-400 Classification Into a Queue

Access control lists (IPv4 and IPv6)

Access group (match access-group command)—Input and output

Address (IPv6 compress mode only)

Name

Number

Source and destination port

TCP flag (IPv4 only)

ATM CLP (match atm clp command)—Input ATM interface

Configurable queue size

CoS (match cos command)—Input and output dot1q tagged frames for 2-Port Gigabit Ethernet SPA only

Frame Relay DE (match fr-de command)—Input Frame Relay interface

Inner CoS (match cos inner command)

IP DSCP (match dscp command)—Input and output

IP precedence (match ip precedence command)—Input and output

MPLS EXP (match mpls experimental command)—Input and output MPLS interface

Multiple matches per class map (up to 8)

Cisco 7600 SIP-400 Congestion Management

CBWFQ

Per-VC CBWFQ

DSCP, EXP and Precedence matching

LLQ or priority queueing (strict priority only)

Dual-priority queuing

http://www.cisco.com/en/US/products/hw/routers/ps368/module_installation_and_configuration_guides_chapter09186a008044013b.html#wp1094663

997
Views
0
Helpful
3
Replies
CreatePlease login to create content