Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Qos on Point to Point Metro-E

Greetings,

Recently we have upgraded three of our branches (main, branch 6, branch 8, branch 9 refer to attached drawing) Point to Point T1 connections to Metro-E (3 mbp P2P Ethernet ). However, since the upgrade there has been a lot of trouble with our phone system (partially VOIP only branch to branch phone servers).There is a lot of jittering while employees are making/talking inter office calls. Moreover, the severity of jittering varies depending on the time of the day. I have concluded that there must be something wrong with my Qos configuration. Also, I have found out that TDS is not doing any kind of Qos on their lines, this is just a simple point to point 3 mb Ethernet.

Attached are a network drawing, branch 6 and main office router configurations. As you can notice we have Star schema configuration where everything happens at the main branch.

Thank you very much for your time appreciate any help,

Best,

E.

Everyone's tags (3)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

If you are only paying for 3Mbps, you must shape your traffic down to 3Mbps on the FastE interfaces.

class-map match-any Transactional-1
match  dscp af21
match  dscp af22
match  dscp af23
class-map match-any Signaling-1
match  dscp cs3
match  dscp af31
class-map match-any Routing-1
match  dscp cs6
class-map match-any Voice-1
match  dscp ef
match  dscp cs5
class-map match-any Management-1
match  dscp cs2
!
!
policy-map SDM-QoS-Policy-1
class Voice-1
    priority percent 33
class Signaling-1
    bandwidth percent 5
class Routing-1
    bandwidth percent 5
class Management-1
    bandwidth percent 5
class Transactional-1
    bandwidth percent 5
class class-default
    fair-queue
     random-detect

policy-map 3Mbps

class class-default

   service-policy SDM-QoS-Policy-1

   shape average 3000000


!
!
!
!
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.31.2.1 255.255.252.0
duplex auto
speed auto
no mop enabled
!
service-policy output QoS-Policy-1
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 172.16.31.1 255.255.255.240
duplex auto
speed auto
!
service-policy output 3Mbps

Regards,

Edison

Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

Your example won't work because you are only shaping the class class-default while you have to shape all classes - that's the reason you have to create a parent policy with a shaper and associate the child policy (your old policy) to it.

I can't answer your SDM question as I never use it. I recommend getting used to the command line.

You should only shape traffic going to the WAN, traffic coming back to you is limited by the Service Provider.

Regards,

Edison

Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

The voice will be ok as long as you've allocated enough for that traffic. 30% is our maximum recommended value. Any higher than 30% can potentially starve other queues. If you find yourself needing more than 30%, I recommend upgrading the bandwidth.

Regards,

Edison

6 REPLIES
Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

If you are only paying for 3Mbps, you must shape your traffic down to 3Mbps on the FastE interfaces.

class-map match-any Transactional-1
match  dscp af21
match  dscp af22
match  dscp af23
class-map match-any Signaling-1
match  dscp cs3
match  dscp af31
class-map match-any Routing-1
match  dscp cs6
class-map match-any Voice-1
match  dscp ef
match  dscp cs5
class-map match-any Management-1
match  dscp cs2
!
!
policy-map SDM-QoS-Policy-1
class Voice-1
    priority percent 33
class Signaling-1
    bandwidth percent 5
class Routing-1
    bandwidth percent 5
class Management-1
    bandwidth percent 5
class Transactional-1
    bandwidth percent 5
class class-default
    fair-queue
     random-detect

policy-map 3Mbps

class class-default

   service-policy SDM-QoS-Policy-1

   shape average 3000000


!
!
!
!
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.31.2.1 255.255.252.0
duplex auto
speed auto
no mop enabled
!
service-policy output QoS-Policy-1
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 172.16.31.1 255.255.255.240
duplex auto
speed auto
!
service-policy output 3Mbps

Regards,

Edison

New Member

Re: Qos on Point to Point Metro-E

Edison,

Thank you so very much for taking you time and looking into this,

Would this work?

class-map match-any SDM-Transactional-1
match  dscp af21
match  dscp af22
match  dscp af23
class-map match-any SDM-Signaling-1
match  dscp cs3
match  dscp af31
class-map match-any SDM-Routing-1
match  dscp cs6
class-map match-any SDM-Voice-1
match  dscp ef
match  dscp cs5
class-map match-any SDM-Management-1
match  dscp cs2
!
policy-map SDM-QoS-Policy-1
class SDM-Voice-1
    priority percent 33
class SDM-Signaling-1
    bandwidth percent 5
class SDM-Routing-1
    bandwidth percent 5
class SDM-Management-1
    bandwidth percent 5
class SDM-Transactional-1
    bandwidth percent 5
class class-default
    fair-queue
     random-detect
    shape average 3000000

!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.31.2.1 255.255.252.0
duplex auto
speed auto
no mop enabled
service-policy output SDM-QoS-Policy-1
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 172.16.31.1 255.255.255.240
duplex auto
speed auto
service-policy output SDM-QoS-Policy-1

By the way, for some reason Cisco SDM wouldn't let me to apply SDM-QoS-Policy-1 simultaneously on both interfaces, am I doing something unsafe?

Should I drop access traffic on the 0/1 Interface facing Metro-E? Is there a way for the 0/1 interface to let the two other routers know that it is receiving/transmitting Voice traffic and can't handle any data at the given point. Kind of like having all four routers under the same umbrella and all know who is doing what (or at least the main office router) and not to overwhelm the main pipe connecting to the main branch.

Best,

E.

Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

Your example won't work because you are only shaping the class class-default while you have to shape all classes - that's the reason you have to create a parent policy with a shaper and associate the child policy (your old policy) to it.

I can't answer your SDM question as I never use it. I recommend getting used to the command line.

You should only shape traffic going to the WAN, traffic coming back to you is limited by the Service Provider.

Regards,

Edison

New Member

Re: Qos on Point to Point Metro-E

Edison,

Wonderful, what you are saying maks sense. I have applied the changes to the routers on all sides. I will monitor the line for a day and will update you. As of now the jittering in the phone call is gone ( thank to you). Do you think when the bandwith gets maxed out the voice is still going to be okay?

class-map match-any RoutingTraffic
match  dscp cs6
class-map match-any SignalingTraffic
match  dscp cs3
match  dscp af31
class-map match-any VoiceTraffic
match  dscp ef
match  dscp cs5
class-map match-any TransactionalTaffic
match  dscp af21
match  dscp af22
match  dscp af23
class-map match-any ManagementTraffic
match  dscp cs2
!
!
policy-map QoS-Policy
class VoiceTraffic
    priority percent 33
class SignalingTraffic
    bandwidth percent 5
class RoutingTraffic
    bandwidth percent 5
class ManagementTraffic
    bandwidth percent 5
class TransactionalTaffic
    bandwidth percent 5
class class-default
    fair-queue
     random-detect
policy-map 3Mbps
class class-default
    shape average 3000000
  service-policy QoS-Policy
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.31.2.1 255.255.252.0
duplex auto
speed auto
no mop enabled
!
service-policy output 3Mbps
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 172.16.31.1 255.255.255.240
duplex auto
speed auto
!

Thank you so very much for your kind/constructive comments,

E.

Hall of Fame Super Bronze

Re: Qos on Point to Point Metro-E

The voice will be ok as long as you've allocated enough for that traffic. 30% is our maximum recommended value. Any higher than 30% can potentially starve other queues. If you find yourself needing more than 30%, I recommend upgrading the bandwidth.

Regards,

Edison

New Member

Re: Qos on Point to Point Metro-E

Edison,

All working very well, no more jittering.

Thank you,

875
Views
0
Helpful
6
Replies
CreatePlease to create content