Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS policy issue on a 4500

I would like to apply an outbound QoS policy on a L2 interface of my 4507 switch where my WAN router is connected.

As soon as I assign the policy, all traffic is retag as DSCP 0

Here are my QoS policy:

Policy Map WAN-Output-Policy

Class VoIP-RTP-Class

set dscp ef

Class VoIP-Control-Class

set dscp af31

Class Video-Class

set dscp af31

Class SAP-Class

set dscp af21

Class BestEffort-Class

set dscp default

Here is the config of the interface:

interface FastEthernet6/1

description WAN Router 1

switchport mode access

service-policy output WAN-Output-Policy

speed 100

duplex full

end

The traffic match my different class-map, however it is not tagged as I want

here is the "sh policy-map interface fa6/1"

Service-policy output: WAN-Output-Policy

Class-map: VoIP-RTP-Class (match-any)

2 packets

Match: access-group name VoIP-RTP-Access-List

2 packets

QoS Set

ip dscp ef

Packets marked 0

Class-map: VoIP-Control-Class (match-any)

647 packets

Match: access-group name VoIP-Control-Access-List

647 packets

QoS Set

ip dscp af31

Packets marked 0

Class-map: Video-Class (match-any)

33 packets

Match: access-group name Video-Access-List

33 packets

QoS Set

ip dscp af31

Packets marked 0

...

Any idea why?

Thanks in advance

Thomas

4 REPLIES
New Member

Re: QoS policy issue on a 4500

Is QoS and IP header DSCP rewrite enabled globally?

Do "show qos".

Blue

Re: QoS policy issue on a 4500

Why dont you post the entire switch config? You didnt post the class maps, just the policy map...

New Member

Re: QoS policy issue on a 4500

Ok, thanks all, I finally found the issue. My policy-maps did match the traffic as I expected (confusion between the source and destination ports). Everything is ok now.

Thank you!

New Member

Re: QoS policy issue on a 4500

Hi, I just want to ask you, how did you solve your problem, i am havig the same problem, using a similar policy as you.

any help will be appreciate

198
Views
0
Helpful
4
Replies