Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

QOS Policy-Map Issue

int vlan XX1

Description Voice_VLAN

service-policy input IP-PHONES

!

XX3750(config)#int vlan 2

BANSW1009(config-if)#service-policy input SOFTPHONES

EERROR MESSAGE:

%QoS: child policy POLICE-256k already used by another parent policy-map IP-PHONES attached to an interface. Service Policy attachment failed

The above error message display when you attempt to apply "service-policy input SOFTPHONES" on 'VLAN XX2' when "service-policy input IP-PHONES" is in place, vice versa.

NOTE:

1. if you remove service-policy input IP-PHONES from VLAN XX1, then apply service-policy input SOFTPHONES on VLAN XX2 it work fine(voice versa), in short you can't used IP-PHONES & SOFTPHONES POLICY MAPS at a time.

Other Info:

1a. (We're stacking three 3750 Switch),

1b. SW Image: C3750-IPSERVICES-M ;

1c. Version:12.2(35)SE2

2. These setup work well with other site.

3750 SWITCH QOS CONFIGURATION.

***********ACCESS CONTROL LISTS***********

ip access-list extended ip-phone-voice

permit udp <enter local site voice vlan ip range here with reverse mask> any range 16384 32767

permit udp any <enter local site voice vlan ip range here with reverse mask> range 16384 32767

!

ip access-list extended signaling

permit tcp any 1719 1720 any

!

ip access-list extended softphone-voice

permit udp any range 30000 30099 any

--------Create Class-Maps -----------

class-map match-all IP-PHONE-VOICE

match access-group name ip-phone-voice

class-map match-all SIGNALING

match access-group name signaling

class-map match-all SOFTPHONE-VOICE

match access-group name softphone-voice

class-map match-all ACCESS-PORTS-STACK1

match input-interface FastEthernet1/0/1 - FastEthernet1/0/46

class-map match-all ACCESS-PORTS-STACK2

match input-interface FastEthernet2/0/1 - FastEthernet2/0/43 FastEthernet2/0/45 FastEthernet2/0/47 - FastEthernet2/0/48

class-map match-all ACCESS-PORTS-STACK3

match input-interface FastEthernet3/0/1 - FastEthernet3/0/48

!

--------Create Policy-Maps -----------

policy-map POLICE-256k

class ACCESS-PORTS-STACK1

police 256000 16000 exceed-action drop

class ACCESS-PORTS-STACK2

police 256000 16000 exceed-action drop

class ACCESS-PORTS-STACK3

police 256000 16000 exceed-action drop

!

policy-map IP-PHONES

class IP-PHONE-VOICE

set dscp ef

service-policy POLICE-256k

class SIGNALING

set dscp cs3

service-policy POLICE-256k

!

policy-map SOFTPHONES

class SOFTPHONE-VOICE

set dscp cs2

service-policy POLICE-256k

class SIGNALING

set dscp cs3

service-policy POLICE-256k

!

--------SERVICE POLICIES -----------

int vlan XX1

Description Voice_VLAN

service-policy input IP-PHONES

!

int vlan XX2

Description DATA_VLAN

2 REPLIES
Hall of Fame Super Silver

Re: QOS Policy-Map Issue

Hello Arnold,

you are trying to use the same policy-map POLICE-256k in two different parent service policy.

Define a new object police-256k-bis that does the same actions as the original one (you may want to use also 3 new class-maps) and use in the second parent policy

%QoS: child policy POLICE-256k already used by another parent policy-map IP-PHONES attached to an interface. Service Policy attachment failed

Probably this is a limitation that comes from the QoS implementation on the multi layer switch.

Hope to help

Giuseppe

Re: QOS Policy-Map Issue

Hi Giuslar,

The same policy-map (and QOS configuration) work well with other sites, the only different here is we're stacking three 3750 Switches, while other sites only two switches. I'm not that sure stackwise causes these issue.

btw, thanks for the reply.

Regards

470
Views
0
Helpful
2
Replies
CreatePlease login to create content