Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS priority by precedence trouble on Catalyst Switch Module 3012

Hello,

We have problem with qos of udp trafic on CBS3012.

There is 2 udp ports. When higher ip precedence of one of them is set, traffic shapes not as should: higher ip precedence level gives lower bitrate and lower precedence gives higher. Tested by iperf on win and freebsd.

Hierarchy looks like this:

virtual mschine with freebsd<---internal port @1G--->cbs3012<---external port @100M--->laptop with win 7

Traffic goes from virtual mashine to laptop.

 

WS-CBS3012-IBM-I   12.2(55)SE4           CBS31X0-UNIVERSAL-M


Current configuration : 4720 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname blade-sw2
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
username admin privilege 15 secret 5
!
!
no aaa new-model
system mtu routing 1500
ip routing
!
!
ip domain-name stc
ip name-server
!
mls qos
!
spanning-tree mode pvst
no spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
no spanning-tree vlan 1-4094
spanning-tree vlan 1 forward-time 10
spanning-tree vlan 1 max-age 10
!
!
!
!
vlan internal allocation policy ascending
!
!
class-map match-any qos-class2
 match access-group name qos-list2
class-map match-any qos-class
 match access-group name qos-list
!
!
policy-map qos-map
 class qos-class
  set ip precedence 5
 class qos-class2
  set ip precedence 0
!
!
!
interface Port-channel2
 switchport trunk allowed vlan 1,10,11,52,53
 switchport mode trunk
!
interface FastEthernet0
 ip address
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
!
interface GigabitEthernet0/1
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1,10,11,30,52,53
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/2
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1,10,11,30,52,53
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/3
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1,10,11,30,52,53
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/4
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1,10,11,30,52,53
 switchport mode access
 spanning-tree portfast trunk
 service-policy input qos-map
!
interface GigabitEthernet0/5
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/6
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/7
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/8
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/9
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/10
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/11
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/12
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/13
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/14
 switchport trunk allowed vlan 1,30
 switchport mode trunk
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/15
 switchport mode access
 speed 100
 service-policy input qos-map
!
interface GigabitEthernet0/16
 switchport mode access
!
interface GigabitEthernet0/17
 switchport mode access
 channel-protocol lacp
!
interface GigabitEthernet0/18
 switchport mode access
 channel-protocol lacp
!
interface Vlan1
 ip address
!
interface Vlan30
 ip address
!
ip default-gateway
ip classless
ip route
ip route
ip route
ip route
ip route
ip route
ip route
ip route
ip route
ip route
ip http server
!
ip access-list extended qos-list
 permit tcp any any eq 63510
 permit udp any any eq 63510
ip access-list extended qos-list2
 permit tcp any any eq 63511
 permit udp any any eq 63511
!
ip sla enable reaction-alerts
!
line con 0
 password 7
 login
line vty 0 4
 exec-timeout 0 0
 password 7
 login local
 history size 50
 transport input all
line vty 5 15
 exec-timeout 0 0
 password 7
 login local
 history size 50
 transport input all
!
mac address-table static   vlan 1002 interface GigabitEthernet0/19
end

Everyone's tags (1)
24
Views
0
Helpful
0
Replies
CreatePlease login to create content