Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS Question

I am trying to setup either a Shaper or something that would tell all the traffic to a certain external IP address to be the highest priority for all data going out. However, I have no idea how to do this as I am very very very new to QoS, etc.

Thank you in advance.

3 REPLIES

Re: QoS Question

Hi,

It sounds like this should be possible. Essentially, you need to "Mark" all of the traffic that you wish to prioritise and then ensure that the Marked traffic receives the highest priority on the router interface.

What equipment are you planning on performing this on? Is it a Cisco Router?


Many thanks

Jonathan

New Member

Re: QoS Question

I will implementing this on a Cisco 2821 router.

Cisco Employee

Re: QoS Question

Hello!

Do you mean that you want to mark the traffic so that the external network knows what are the priority packets, or do want to ensure that when there is congestion the priority packets are not delayed/dropped?

The problem when we want to prioritize traffic is that it has to be done where you'll have a "bottleneck". This is where the packets will start to be enqueued, usually that will be in a fifo queue if there is no QoS, and so the priority packets may be delayed unless you prioritize them. If the external network is already doing queueing based on packet marked, you'll just need to mark the packets on the router, if not, you'll have to make sure you don't send that traffic a higher rate than the external network bandwidth.

I'm telling this as you are talking about a shaper, in your case a shaper will be useful if you don't have control on the external network that has a lower overall bandwidth than your router interface speed. For example, if you have a FastEthernet interface but your ISP provide only 10Mb, you'll want to add a shaper at 10Mb on your router so that in case of congestion you can send the priority packets first, and since no other queueing should occur in the ISP network the priority packets won't be delayed.

You are not obliged to configure a shaper, and configure only queueing, so we'll enqueue the packets only when there is congestion (when the traffic rate is above interface speed) and the priority packets can leave the router first, the other packets will be enqueued.

If you need to match only packets to a certain destination IP address, a typical example is:

class-map priority-traffic
 match access-list 100
! policy-map child-pol
 class priority-traffic
  priority 512
 !NOTE: there is an implicit class default that will 
        have the rest of the bandwidth

!

policy-map parent-pol
 class class-default
  shape average 10000000
  service-policy child-pol
!
interface FastEthernet0/0
 service-policy output parent-pol
access-list 100 permit ip any  

You need to create a class of traffic, here named "priority-traffic" that will classify packets using an ACL.

Then you define a child service policy that will define how the queues will look like inside the shaper configured in the parent.

And finally, apply this on output of your interface.

Now, if you just need to mark the packets to tell the external network they are priority packets, just do the following:

class-map priority-traffic

 match access-list 100
! policy-map marking
 class priority-traffic
  set dscp  ! This should be the DSCP the external 
                     network knows for priority packets

!

interface FastEthernet0/0
 service-policy output marking
!
access-list 100 permit ip any  

190
Views
0
Helpful
3
Replies
CreatePlease to create content