Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Question about ip helper-address in VRF environnement

Hello,

I have a question about DHCP in VRF environnement.

Attached file is my architecture.

The configuration of the switch is the following :

ip vrf SRV

ip vrf USR
!

interface Vlan1
description SERVER

ip vrf forwarding SRV
ip address 10.1.1.254 255.255.255.0
ip directed-broadcast

!

interface Vlan2

ip vrf forwarding SRV
ip address 10.2.2.254 255.255.255.0
ip helper-address 10.1.1.1
ip directed-broadcast

!

interface Vlan3

ip vrf forwarding USR
ip address 10.3.3.254 255.255.255.0
ip helper-address 10.1.1.1
ip directed-broadcast

!

interface Vlan11

ip vrf forwarding SRV
ip address 192.168.11.254 255.255.255.0
ip directed-broadcast

!

interface Vlan10

ip vrf forwarding USR
ip address 192.168.10.254 255.255.255.0
ip directed-broadcast

ip route vrf SRV 0.0.0.0 0.0.0.0 192.168.11.253

ip route vrf USR 0.0.0.0 0.0.0.0 192.168.10.253

The routing inter VRF is assume with the firewall (pass all for the moment).

My problem is that the DHCP client in the VLAN2 receive an IP address with the DHCP Server.

But the DHCP client in the VLAN3 does not receive an IP address with the DHCP Server.

Could you explain to me this problem (error in my configuration, ...etc)?

Thank you.

Regards.

2 REPLIES

Re: Question about ip helper-address in VRF environnement

Hi Laurent,

In your senario you have configured two VRF &  VLAN1 & VLAN 2 are in same VRF ,reasone that you are able to get the IP from DHCP.

But VLAN 3 is in USR VRF , So USR VRF cannot communicate with SRV VRF DHVP Server.

VRF is Routing Instance which have different routing table for each VRF.

Different VRF cannot communicate until an unless you configured them to communicate.

You can check that from USR VRF you will not able to ping DHCP server. Because in USR routing table you will not see any network or route for your DHCP server( 10.1.1.1 ).

But in SRV VRF you can see the network 10.1.1.X & will able to ping DHCP server.

Regards

Chetan kumar

New Member

Re: Question about ip helper-address in VRF environnement

Hi Chetan,

Thank you for your response.

I have resolved the problem : bad gateway for the IP Vlan 3.

Regards.

4352
Views
0
Helpful
2
Replies