Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

question in route map

i have a question in route map ,

i have two routers connected as shown :

R1-----------------------------------------R2

im using eigrp protocols and here is the configuration :

R1

interface Loopback0

ip address 13.13.13.13 255.255.255.0

!        

interface Loopback1

ip address 14.14.14.14 255.255.255.0

!        

interface Loopback3

ip address 15.15.15.15 255.255.255.0

!        

interface FastEthernet0/0

ip address 192.168.1.6 255.255.255.252

duplex auto

speed auto

!        

router eigrp 1

network 13.0.0.0

network 14.0.0.0

network 15.0.0.0

network 192.168.1.0

distribute-list route-map virus out

no auto-summary

!        

ip http server

no ip http secure-server

!        

ip classless

!        

!        

!        

ip prefix-list ahmd seq 1 deny 13.13.13.0/24

ip prefix-list ahmd seq 2 permit 0.0.0.0/0 le 32

!        

route-map virus permit 1

match ip address prefix-list ahmd

!        

route-map virus deny 2

match ip address prefix-list ahmd

!        

!        

control-plane

my question is why the other  routes "" any route except 13.13.13.0/24 "" will be allowed ????????

i mean that  in the route map in line 1 i permited any thing except 13.13.13.0/24

and in the line 2

i returned and denied any thing except 13.13.13..0/24

but when i wen to the 2nd router i found the networks 14.14.14.0 and 15.15.15.0 !!!!!!!!!!!!!

my question is ,does  any thing matched with a route map line ""whaterver it wasd permit or deny ""  will not be available for  matching in the next sequence lines??????

thanks alot

2 REPLIES
Community Member

Re: question in route map

Yes, route-map processing is similar to acl's in that, when it finds a match/hit it will stop processing the rest of the list.

If you are trying to deny all routes except 13.13.13.0/24 All you really need to do is permit the route you want & the implicit deny will catch the other routes,

ip prefix-list ahmd seq 1 permit 13.13.13.0/24

route-map virus permit 1

match ip address prefix-list ahmd

Community Member

Re: question in route map

,,,,,,,,,, thank u s0000 much

i just wanted to assure from this point

thanks alot

216
Views
2
Helpful
2
Replies
CreatePlease to create content