Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Question re: etherchannel config

I'm putting a 2 port channel in on a 4506 running 12.2(25). It's connecting to an ESX server.

Can I get a sanity check on these configs?

interface Port-channel1

description Channel to ESX1 ports 3/42 & 3/38

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

interface GigabitEthernet3/42

description ESX1 managment

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode on

interface GigabitEthernet3/38

description ESX1 managment

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode on

The ESX server is intermittently losing connections with this config. I'm not entirely sure it's not an issue with the 4500's switch ports.

Thanks

14 REPLIES
Purple

Re: Question re: etherchannel config

Is there a reason that you have to trunk the connection if only 1 vlan is allowed ? You would also have to get verification from the server guys on how they set up their nics for etherchannel . Make sure they are not trying to use LACP or something like that .

New Member

Re: Question re: etherchannel config

It's just the initial configuration, I anticipate using at least 2 more once the environment is stable.

Hall of Fame Super Blue

Re: Question re: etherchannel config

Roland

If you are only allowing vlan 200 then why have you configured it as a trunk and not as an access port(s) in vlan 200.

Jon

New Member

Re: Question re: etherchannel config

It's just the initial configuration until the environment is stable. We plan to have at least 3 VLAN's total on day 1.

New Member

Re: Question re: etherchannel config

If I'm remembering correctly, when we did Etherchannel on ESX boxes it had to be setup for LACP passive. Which is "channel-group # mode passive".

edited to correct my Acronym.

New Member

Re: Question re: etherchannel config

Thanks for the suggestion but it doesn't work for me. If I leave the port-channel set to on the switch ports stay up but the virtual switch ports bounce about every 5 minutes.

Re: Question re: etherchannel config

Try removing the config from the port channel interface and see if that keeps your etherchannel up.

I have the same type setup, but my configurations are on the physical ports and not the etherchannel. I'm running a 3750 though, and my etherchannel connects to an AIX server.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Question re: etherchannel config

Should these statements be in the config for the channel interface? The documentation isn't very clear.

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

interface Port-channel1

description Channel to ESX1 ports 3/42 & 3/38

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

Re: Question re: etherchannel config

As in my previous post, I don't have anything configured on the etherchannel interface. Adding the physical ports to the channel group is enough to bring the etherchannel up.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Question re: etherchannel config

Thanks, I wasn't sure if that was what you meant. I'm trying that now.

New Member

Re: Question re: etherchannel config

Hi Roland,

Are you connecting to HP blades using virtual connect by any chance?

I had a similar problem, solved by switching on lacp. I also had to keep the port channel (and all its members) shutdown whilst the ESX host booted up. Once the host had started I did a no shut on all the ports.

hth

Kevin

New Member

Re: Question re: etherchannel config

Kevin

I saw your post when I searched before making this post. No I'm using an IBM server as the host and when I used lacp it didn't work. I tried both passive and active and neither worked. When I set the channel to "on" the ports transition to an up/up state on the 4500 but the ESX seems to intermittently lose it's connetions.

Thanks for your suggestion though. I will try to reboot the ESX while my ports are shut down and see if that helps.

New Member

Re: Question re: etherchannel config

ah, okay!

Only other thing I could suggest is to go through the VMWare hardware compatibility list very very carefully indeed.

ESX is very sensitive to things like firmware revisions on nic's etc.

Good luck.

Kevin

New Member

Re: Question re: etherchannel config

Ok, my configs were fine. I got it running with ESX 3 using the mode set to 'on'. The problem was resolved when we set the NIC on the ESX servers to use the ip hash setting.

399
Views
0
Helpful
14
Replies