Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Question Regarding switchport trunk

All, recently I inherited the switches at our facility. Upon review of the configs, I found this config for a port that is connected to a ISCSI SAN:

switchport access vlan 100

switchport trunk pruning vlan 100

switchport mode access

flowcontrol receive desired

spanning-tree portfast

My question is: Is it incorrect to have "switchport trunk pruning vlan 100" on this interface?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Question Regarding switchport trunk

no never for access port...

You can remove all settings belongs to trunk port and add

switchport mode access

span..tree portfast

5 REPLIES
Hall of Fame Super Bronze

Re: Question Regarding switchport trunk

That port current mode is 'access'. The pruning command is not doing anything at the moment.

If you were to change the command

switchport mode access

to

switchport mode trunk

All Vlans will be allowed on this trunk except vlan 100.

You can verify more information on the switchport by typing

show int fa0/0 switchport

replace fa0/0 with the interface and port number.

New Member

Re: Question Regarding switchport trunk

but, I dont want the port to be a trunk port, if its an end user port, correct? Based on the config, how does the port know to be in trunking mode or access? Should a end user port ever be in trunking mode?

New Member

Re: Question Regarding switchport trunk

no never for access port...

You can remove all settings belongs to trunk port and add

switchport mode access

span..tree portfast

Re: Question Regarding switchport trunk

Hi,

You are right, a user port should always be an access port, the "switchport trunk pruning vlan 100" command has no meaning here, and thus it has no effect here.

You only need:

switchport mode access

switchport access vlan 100

spanning-tree portfast

P.S Please see my reply on your other post "Another Question regarding Switchport trunk, mode, and Trunk"

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Hall of Fame Super Bronze

Re: Question Regarding switchport trunk

The config you posted clearly says to place the port in 'access' mode with the command

switchport mode access

by default, a layer 2 switchport is set to dynamic desirable (3550 use dynamic auto).

Dynamic desirable will trunk automatically if the other devices replies to DTP packets, if it doesn't the port will be set to access mode.

For user connection, you don't need trunking. Access mode is the recommended setting.

120
Views
10
Helpful
5
Replies