Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Question with update IOS Switch 2960

Hi,

I want upgrade my switches 2960-24PC-L RAM: 128MB and Flash: 28MB, but in the web page of cisco I see that the requirement of hardware is RAM: 128MB and Flash: 32MB.

I download the IOS file and this file is only 11.2MB so my question is if I can upgrade the IOS because my flash is enough for upload the IOS file.

Thanks.

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Question with update IOS Switch 2960

Yes, it'll work as long as you have enough flash memory available in your appliance.

12 REPLIES
Hall of Fame Super Gold

Re: Question with update IOS Switch 2960

I download the IOS file

What file?  Can you please be specific?

I have >200 2960-24PC fleet and they are now running 15.0(1)SE2 (soon will be upgrading to SE3 if the testing goes well).

Question with update IOS Switch 2960

I want upgrade with the IOS c2960-lanbasek9-mz.122-58.SE2.bin.

Thanks

Hall of Fame Super Gold

Question with update IOS Switch 2960

Yes, it'll work as long as you have enough flash memory available in your appliance.

Question with update IOS Switch 2960

Yes, I have enough space in the flash memory but I don't know why in the web page of Cisco say that I need 32MB in flash memory. I will upgrade and I will post how is working.

Thanks

VIP Purple

Question with update IOS Switch 2960

Hi Adrian,

Yes it will work but ..there is a specific requirement from the vendor side of 32GB.

Personally i feel it is not a problem because mostly IOS take 16MB size but upload on your risk.

Regards

Please rate if it helps.

Hall of Fame Super Gold

Re: Question with update IOS Switch 2960

Yes, I have enough space in the flash memory but I don't know why in the web page of Cisco say that I need 32MB in flash memory. I will upgrade and I will post how is working.

Hence, the reason why a majority of Cisco users never use (and recommend) HTML to manage switches, routers and WAPs.

Use CLI instead.  The command is very, very simple:

1.  If you have a TAR file, then the command is:  archive download-sw [/overwrite] tftp:///FILENAME.TAR

2.  If you have the BIN file, then the command is:  copy tftp:///FILENAME.BIN flash:

IMPORTANT NOTE:   Whatever process you use, make sure you verify the MD5 checksum of the BIN file and compare the values to the Cisco Download website.  This will ensure that the BIN file is not corrupted and was uploaded to the appliance completely.

The command to check the MD5 value is:  verify /md5 flash:FILENAME.BIN

Question with update IOS Switch 2960

I made the upgrade with 2 switches a 2960-24TC-L and 2960-24PC-L and didn't work, there is a bug. The bug is that I can't get into the cli of my switches through ssh or telnet, when I connected by consola the only message that the cli show me is:

%% Low on memory; try again later

%% Low on memory; try again later

Because this bug I have to downgrade to the old version.

Hall of Fame Super Gold

Question with update IOS Switch 2960

I made the upgrade with 2 switches a 2960-24TC-L and 2960-24PC-L and didn't work, there is a bug.

Can you please elaborate further?

What happens when you try to upgrade?

What IOS are you trying to upgrade?

Either use 12.2(55)SE5 or 15.0(1)SE3.

Question with update IOS Switch 2960

Sorry, these switches have the IOS:

WS-C2960-24PC-L    12.2(50)SE4

WS-C2960-24TC-L    12.2(44)SE6

I made the upgrade both to the IOS 12.2(58)SE2, every switch worked with the new IOS the issue was that I can't get into the cli of my switches through ssh  or telnet, when I connected by console the only message that the cli  showed me is:

%% Low on memory; try again later

%% Low on memory; try again later

I found that this is a bug

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCts52797

Thanks.

Hall of Fame Super Gold

Question with update IOS Switch 2960

Don't have to click on the link you've posted.  I've seen this bug several times particularly affecting PoE of the 2960.  I first saw it in 15.0(1)SE1.

Do NOT use 12.2(58)SE or later.  Either use IOS version 12.2(55)SE5 or 15.0(1)SE3. 

Re: Question with update IOS Switch 2960

Did you see some problem with the IOS 15.0(1)SE3? Because this IOS have been released the last month and I am worried about the estability.

Thanks

Hall of Fame Super Gold

Question with update IOS Switch 2960

I'm testing 15.0(1)SE3 as we speak.  Don't have a definite answer as of yet.

The memory leak issue regarding the 2960 PoE line was "somewhat" fixed in 15.0(1)SE2.

3844
Views
8
Helpful
12
Replies
CreatePlease to create content