Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Questions about auto-rp

I have configured two routers to have RP of the same group 239.0.0.1, at any one time there should one RP for group 239.0.0.1, what I understand if there are two auto-rp for the same group the highest ip address wins the RP election, however this is not the case....

I just want to clarify if there are two auto-rp of the same group which router is elected as the RP?

Router 1 multicast configuration

ip pim send-rp-announce Loopback0 scope 5 group-list 1

ip pim send-rp-discovery scope 5

access-list 1 permit 239.0.0.1

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip router isis

ip pim sparse-dense-mode

end

!

interface Vlan30

ip address 192.168.30.1 255.255.255.0

ip router isis

ip pim sparse-dense-mode

end

!

interface Loopback0

ip address 192.168.100.150 255.255.255.255

ip router isis

ip pim sparse-dense-mode

end

ip multicast-routing

Router 2 multicast configuration

ip pim send-rp-announce Loopback0 scope 5

ip pim send-rp-discovery scope 5

!

interface Vlan10

ip address 192.168.10.2 255.255.255.0

ip router isis

ip pim sparse-dense-mode

end

!

interface Vlan30

ip address 192.168.30.2 255.255.255.0

ip router isis

ip pim sparse-dense-mode

end

!

interface Loopback0

ip address 192.168.100.151 255.255.255.255

ip router isis

ip pim sparse-dense-mode

end

ip multicast-routing

mroute

By right router 2 should be the RP since its loopback address is higher than router 1. But...

C7609-2#sh ip mroute 239.0.0.1

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 01:46:45/stopped, RP 192.168.100.150, flags: SJPCF

  Incoming interface: Vlan30, RPF nbr 192.168.30.1, Partial-SC

  Outgoing interface list: Null

(192.168.10.103, 239.0.0.1), 00:50:00/00:02:50, flags: FT

  Incoming interface: Vlan10, RPF nbr 0.0.0.0, RPF-MFD

  Outgoing interface list:

    Vlan30, Forward/Sparse-Dense, 00:50:01/00:02:26, H, A

C7609-2#

When I shutdown router1's loopback0 interface router2's loopback0 becomes the RP, I would like to clarify if two auto-rps are configured for the same MC group the highest ip address wins the RP election right? Or is it the other way round....

Thanks.



Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Questions about auto-rp

Hello,

Your setup is slightly more complex in that one of the RP candidates advertises a list of groups for which it is interested to become a RP while the other RP candidate would like to become a RP for all multicast groups. Perhaps this interaction modifies the selection.

I suggest you go over the AutoRP specification in these two documents carefully - sorry for simply diverting you to another document but I believe that the behavior will be described there.

ftp://ftp-eng.cisco.com/ipmulticast/specs/pim-autorp-spec01.txt

ftp://ftp-eng.cisco.com/ipmulticast/autorp.html

Best regards,

Peter

2 REPLIES
Cisco Employee

Questions about auto-rp

Hello,

Your setup is slightly more complex in that one of the RP candidates advertises a list of groups for which it is interested to become a RP while the other RP candidate would like to become a RP for all multicast groups. Perhaps this interaction modifies the selection.

I suggest you go over the AutoRP specification in these two documents carefully - sorry for simply diverting you to another document but I believe that the behavior will be described there.

ftp://ftp-eng.cisco.com/ipmulticast/specs/pim-autorp-spec01.txt

ftp://ftp-eng.cisco.com/ipmulticast/autorp.html

Best regards,

Peter

New Member

Questions about auto-rp

Hi,

thank you for your reply. I have found the answers minutes ago..... I turn on debug ip pim auto-rp and found that my router1 did not receive RP announcement from router2, whereas router2 receivee RP announcement from itself as well as from router1. the reason why router1 loopback address is the RP despite lower than router1 loopback address because there is no RP announcement to challenge the election. Thanks again for looking into this....

281
Views
0
Helpful
2
Replies
CreatePlease to create content