Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

"%PLATFORM_RPC-3-MSG_THROTTLED" in log

there are a lot of messages in log like this:

%PLATFORM_RPC-3-MSG_THROTTLED: RPC Msg Dropped by throttle mechanism: type 3, class 21, max_msg 8, total throttled 1355

-Traceback= 5FFCA4 43876C 4388B4 4392EC 439510 1E25F0

And the CPU utilization turns to 47% from 6%. There is no flow in all ports except vlan1.

#sh proc cpu | e 0.00

CPU utilization for five seconds: 43%/8%; one minute: 47%; five minutes: 47%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

5 650327593594269354 18 7.52% 6.10% 7.27% 0 Pool Manager

30 1718957 264721815 6 0.16% 0.07% 0.03% 0 Fifo Error Detec

68 7002122028202361 0 0.16% 0.17% 0.16% 0 Hulc LED Process

104 73389293 509261581 144 22.22% 25.51% 25.96% 0 IP Input

8 REPLIES
New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

Please check the link below.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750e_3560e/software/release/12.2_35_se2/release/notes/OL9778.html

Seems like there are too many ARP requests generated out of the some port which has security feature like NAC enabled on it.

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

Could you tell me how to confirm it ?

And I have checked that there is no snmp-server ifindex persist configured.

Thank you very much!

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

Can you post the configuration of the switch? specifically the switch port configuration.

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

version 12.1

no service pad

service tcp-keepalives-in

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

logging buffered 40960 debugging

!

clock timezone CST 8

ip subnet-zero

no ip source-route

ip routing

!

no ip domain-lookup

vtp domain ***

vtp mode transparent

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1 priority 8192

!

!

vlan 100

!

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

!

interface GigabitEthernet1/0/1

.

.

interface GigabitEthernet1/0/19

no switchport

ip address *****

load-interval 30

!

interface GigabitEthernet1/0/20

.

.

.

interface GigabitEthernet2/0/24

load-interval 60

!

interface GigabitEthernet2/0/25

!

.

.

.

!

interface GigabitEthernet3/0/22

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet3/0/23

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet3/0/24

switchport access vlan 100

switchport mode access

load-interval 30

duplex full

speed 100

!

interface GigabitEthernet3/0/25

!

interface GigabitEthernet3/0/26

!

interface GigabitEthernet3/0/27

!

interface GigabitEthernet3/0/28

switchport access vlan 100

switchport mode access

load-interval 30

!

interface GigabitEthernet4/0/1

load-interval 30

speed 100

!

interface GigabitEthernet4/0/2

.

.

interface GigabitEthernet4/0/11

spanning-tree portfast

!

interface GigabitEthernet4/0/12

!

interface GigabitEthernet4/0/13

spanning-tree portfast

!

interface GigabitEthernet4/0/14

.

.

interface GigabitEthernet4/0/28

!

interface Vlan1

ip address *** 255.255.255.0

no ip redirects

standby 13 ip **

standby 13 timers 1 3

standby 13 priority 150

standby 13 preempt

!

interface Vlan100

ip address *** 255.255.255.240

no ip redirects

!

router eigrp **

network **.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 *****

no ip http server

!

logging ***

snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps fru-ctrl

snmp-server enable traps flash insertion removal

snmp-server enable traps bridge

snmp-server enable traps stpx

snmp-server enable traps rtr

snmp-server enable traps port-security

snmp-server enable traps vtp

snmp-server enable traps vlancreate

snmp-server enable traps vlandelete

snmp-server enable traps MAC-Notification

snmp-server enable traps envmon fan shutdown supply temperature

snmp-server enable traps hsrp

snmp-server enable traps cluster

snmp-server enable traps copy-config

snmp-server enable traps syslog

snmp-server enable traps bgp

snmp-server enable traps vlan-membership

!

line con 0

line vty 0 4

login local

line vty 5 15

exec-timeout 30 0

no login

!

ntp clock-period 36028679

ntp server ***

ntp server ***

ntp server ***

!

monitor session 1 source vlan 100

monitor session 1 destination interface Gi3/0/1

end

there are a few multicasts in 3 ports and only the 3 ports are configured IP address.

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

http://www.cisco.com/en/US/customer/docs/switches/lan/catalyst3550/software/release/12.1_19_ea1/configuration/guide/swuncli.html#wp1012800

The above link contains the unsupported commands in 3750. Can you please try removing the commands listed.

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

I cannot access the link, "Forbidden File or Application" is appeared.

any else could I do ?

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

Please find the related list below.

Unsupported User EXEC Commands

ifindex

private-vlan

Unsupported Global Configuration Commands

spanning-tree etherchannel guard misconfig

Unsupported Global Configuration Commands

snmp-server enable informs

snmp-server enable traps flash insertion

snmp-server enable traps flash removal

snmp-server ifindex persist

Unsupported Interface Configuration Commands

ip accounting

ip load-sharing [per-packet]

ip mtu bytes

ip route-cache

ip verify

ip unnumbered type number

All ip security commands

Unsupported Global Configuration Commands

ip accounting-list ip-address wildcard

ip accounting-transits count

ip cef accounting [per-prefix] [non-recursive]

ip cef traffic-statistics [load-interval seconds] [update-rate seconds]]

ip flow-aggregation

ip flow-cache

ip flow-export

ip gratituitous-arps

ip local

ip reflexive-list

router egp

router-isis

router iso-igrp

router mobile

router odr

router static

Unsupported Interface Configuration Commands

frame-relay ip rtp header-compression [active | passive]

frame-relay map ip ip-address dlci [broadcast] compress

frame-relay map ip ip-address dlci rtp header-compression [active | passive]

ip igmp helper-address ip-address

ip multicast helper-map {group-address | broadcast} {broadcast-address | multicast-address} extended-access-list-number

ip multicast rate-limit {in | out} [video | whiteboard] [group-list access-list] [source-list access-list] kbps

ip multicast use-functional

ip pim minimum-vc-rate pps

ip pim multipoint-signalling

ip pim nbma-mode

ip pim vc-count number

ip rtp compression-connections number

ip rtp header-compression [passive]

Unsupported Global Configuration Commands

ip pim accept-rp {address | auto-rp} [group-access-list-number]

ip pim message-interval seconds

New Member

Re: "%PLATFORM_RPC-3-MSG_THROTTLED" in log

There is no unsupported commands in my switch.

And I find a strange thing about flow. There are 2 vlans in switch, the input rate of vlan1 is 13Mb/sec and the output rate of vlan2 is 12Mb/sec. There is no flow in other ports both input and output. Why would be this ?

910
Views
7
Helpful
8
Replies
CreatePlease to create content