Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

"spanning-tree vlan x cost y" disappears from configuration

I ran into an odd behaviour on a 3560-E, WS-C3560E-24TD with IOS 12.2(55)SE.

I'm running Rapid PVST:

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree logging

spanning-tree extend system-id

spanning-tree pathcost method long

I have an interface in trunk mode, connected to another switch; only 1 VLAN is extended on this trunk, and I configured a specific STP port cost for it:

interface GigabitEthernet0/8

description To-Switch-1

switchport trunk encapsulation dot1q

switchport trunk native vlan 123

switchport trunk allowed vlan 123

switchport mode trunk

switchport nonegotiate

spanning-tree vlan 123 cost 100000

If I unplug the cable, the spanning-tree vlan 123 cost 100000 line disappears from the interface configuration. Even if the port comes up the configuration line does not appear again.

In order to avoid this issue I had to use the spanning-tree cost 100000 command, but it just has sense because at this time I only have 1 VLAN on the trunk.

Anyone can help me? What am I missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

"spanning-tree vlan x cost y" disappears from configuration

Hi,

There is a bug filed for this and developers are actively working on this.

- http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtj03875

Cheers,

Somu

Rate helpful posts

2 REPLIES
Cisco Employee

"spanning-tree vlan x cost y" disappears from configuration

Hi,

There is a bug filed for this and developers are actively working on this.

- http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtj03875

Cheers,

Somu

Rate helpful posts

Bronze

"spanning-tree vlan x cost y" disappears from configuration

798
Views
10
Helpful
2
Replies
CreatePlease to create content