Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Re : Question on QoS ...

Hi,

I have a scenario here whereby I have a site in India that is accessing a Citrix application in a site in the US.

The source IP subnet is 135.75.15.0/24 and the destinatin IP subnet is 145.75.15.0/24

On the source IP subnet, I have done the following :-

ip access-list extended match-citrix

permit tcp any eq 1494 any

permit tcp any any eq 1494

permit tcp any eq 2598 any

permit tcp any any eq 2598

!

!

class-map match-all Citrix

match access-group name match-citrix

!

policy-map QoS_C

class Citrix

set ip dscp af21

!

!

int g0/5

service-policy input QoS_C

!

!

-----------------------------------------

On the destination end, the folowing configuration ....

ip access-list extended match-citrix

permit tcp any eq 1494 any

permit tcp any any eq 1494

permit tcp any eq 2598 any

permit tcp any any eq 2598

!

!

class-map match-all Citrix

match access-group name match-citrix

!

policy-map QoS_C

class Citrix

set ip dscp af21

!

!

int g0/8

service-policy output QoS_C

-----------------------------------

My q's are as follows :-

1) Is this configuration correct to address this issue on both ends ? ...

2) How do I know that the QoS is working per the configuration ....

3) Any other way to do the above task ?

Thank you,

Cheers,

- InternetB -

3 REPLIES

Re: Re : Question on QoS ...

first of all

upon the above config u done only the classification and marking stage

let me give a simple background first

with QoS

we need first to calssify and mark our traffic then after that we can match our traffic based on the marking it have and then we can give prefrence to kind of traffic over other kind

in ur example u when to reserve an amound of bandwidth for citrix app traffic so in case of the nework conjested at least u can garantee that traffic can flow

i have cuple of questions to let me kow how to apply the policies and where

first what kind of connection u have

and is the g0/5 and 5/8 router switch port?

and about ur above policy

u have don only marking as i mentoion above

i will give u here config in general regarding ur case and traffic type

ip access-list extended match-citrix

permit tcp any eq 1494 any

permit tcp any any eq 1494

permit tcp any eq 2598 any

permit tcp any any eq 2598

!

!

class-map match-any Citrix

match access-group name match-citrix

Note: i change the class map from match all to any in this case any traffic that match any port included in that ACl withing this class will be matched

with all

the class will be matched only if the traffic contain all the prots together.

now what we need to make simplified

i will consider g0/5 is the output interface to the remote site

so do the following in ur policy

policy-map QoS_C

class Citrix

bandwidth percent 40

class class-default

fair-queue

based on the above policy

if the link get conjested u gonna garnatee at leat 4% for the citrix traffic

int g0/5

service-policy output QoS_C

and the same idea apply to the other side

and u can put more class amd make more complicated polies but the basic idea is the same as above

good luck

please, if helpful Rate

Super Bronze

Re: Re : Question on QoS ...

"1) Is this configuration correct to address this issue on both ends ? ... "

Insufficient information. Without knowing your WAN technology, there could be congestion within something like a WAN cloud.

That noted, on your first part of your example, you show your policy being applied inbound (input) and on the second part applied outbound (output). Normally would expect an outbound policy on both ends.

Also you're only marking, and again without knowing your WAN technology and topology, that might be insufficient.

"2) How do I know that the QoS is working per the configuration .... "

Show "show policy-map interface" would provide you some stats. Beyond that, SLA tests that confirm your expectations.

"3) Any other way to do the above task ?"

Probably, but again, need more information before making specific suggestions.

PS:

On later IOSs, at least most routers, NBAR can match against Citrix traffic. Also offers the abililty to match against the type of Citrix packet. (Unsure whether it would properly handle Citrix traffic on a non-"Citrix" port.)

Re: Re : Question on QoS ...

hi Joseph

u right 100%

but what i have dont for him is i made the bisic Qos condig inregard to his config

i have randamly assigned the bandwidth but what i wanted to do is to make defrence between what has done and what the config should look regardless the technolgy in use i mean just the idea of matching and then give the bandwidth or policy upon the class map

again if he put more info we can give more presice solusions

thanks

123
Views
0
Helpful
3
Replies
CreatePlease to create content