Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Recovering 2950 Ios

Dear Sir,

I have typed 'erase flash' command by mistake in my catalyst 2950 switch. After reboot, it stopped at "switch:" prompt.No IOS File Is Present In the FLASH, i Am having backup of ios & i tried to Restore using hyper ternimal, xmodem option,But it is giving the message "remote system is not responding". So what should i do for reinstalling the IOS.

Please help me as early as possible.

With Regards

Sumit Patil.

91-09370199642

5 REPLIES
Bronze

Re: Recovering 2950 Ios

Here is a guide on recovering the switch. If you have a helper image still loaded you should be able to tftp it after you load the helper image, otherwise, there is a step by step guide to using xmodem and also increasing the console speed to speed up the transfer.

http://www.cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml

GL

-Rob

New Member

Re: Recovering 2950 Ios

I Had Tried The Xmodem Recovery,But It Had Not Worked It Is Displaying Remote System Cannot Respond,The Images Are Attached.

Please Help Me Out Of this Problem.

New Member

Re: Recovering 2950 Ios

I had tried the displayed procedure i.e using xmodem but it is giving the message after sometime that "remote system cannot respond".Please give me the solution.

With Regards

Sumit Patil

Bronze

Re: Recovering 2950 Ios

I don't have a 2950 to try but if you are in rommon and have the tftpdnld command available, try this:

rommon 1>IP_ADDRESS=192.168.100.1 Indicates the IP address for this unit

rommon 2>IP_SUBNET_MASK=255.255.255.0 Indicates the subnet mask for this unit

rommon 3>DEFAULT_GATEWAY=192.168.100.1 Indicates the default gateway for this unit

rommon 4>TFTP_SERVER=192.168.100.2 Indicates the IP address of the TFTP server

rommon 5>TFTP_FILE= c2600-js-l_121-3.bin Indicates the filename to fetch from the TFTP server

rommon 6>tftpdnld

Other questions: is your new ios bigger then your available flash? What is in flash?

I have a 2950 somewhere, just have to go dig it up, will respond again with more details once I locate a switch to test with.

New Member

Re: Recovering 2950 Ios

Please post the exact steps in your attempt to restore image. Sounds like you're missing a step

1439
Views
0
Helpful
5
Replies
CreatePlease to create content