Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

redistribure route between vrf ?

Hi,

I am new in configuring vrf .

I configured my 6k to be two vrf domain, now I can only see the routes which belong to them individully. How can I redistribute the routes between these two vrf domain and let them see peer routes?

Also why there is no routes on the main 6k routing table, only in the vrf routing table?

My purpose is divided this 6k to multiple virtual routers and each router maintain its own routing table.

Below is my confige so far, thanks

!!!!!!!!!!!!!!!!!!!!

ip vrf lab-1

rd 800:2

!

ip vrf lab-server

rd 800:1

!

!

interface Vlan333

ip vrf forwarding lab-server

ip address 172.x.x.1 255.255.255.0

!

interface Vlan444

ip vrf forwarding lab-1

ip address 10.x.x1 255.255.0.0

!

router eigrp 444

redistribute connected

redistribute eigrp 333

no redistribute eigrp 444

no auto-summary

!

address-family ipv4 vrf lab-1

redistribute connected

no redistribute eigrp

network 10.x.x.x 0.0.255.255

no auto-summary

autonomous-system 444

exit-address-family

!

router eigrp 333

redistribute connected

redistribute eigrp 444

no auto-summary

!

address-family ipv4 vrf lab-server

redistribute connected

redistribute eigrp

network 172.x.x.x 0.0.0.255

no auto-summary

autonomous-system 333

exit-address-family

2 REPLIES

Re: redistribure route between vrf ?

Under the VRF you need to look at import & export to pass routes from one VRF to another.

Community Member

Re: redistribure route between vrf ?

Thanks for reply.

#route-target export|import

I saw a cisco document says this command is effective only if BGP is running, what's that mean? Do I need enable BGP on this 6k to enable the redistribute?

145
Views
0
Helpful
2
Replies
CreatePlease to create content