Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistribute BGP learned default route into EIGRP

Hi,

I would like to redistribute a BGP learned default route into EIGRP. I'm using the following config:

router eigrp 65101

redistribute bgp 65101 route-map BGP_DEFAULT_ROUTE_RM

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

network 1.1.1.0 0.0.0.63

no auto-summary

eigrp router-id 1.1.1.1

!

router bgp 65101

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

network 1.1.1.0 mask 255.255.255.192

neighbor 2.1.1.1 remote-as 64000

no auto-summary

route-map BGP_DEFAULT_ROUTE_RM permit 10

match ip address prefix-list DEFAULT_ROUTE_PL

ip prefix-list DEFAULT_ROUTE_PL seq 5 permit 0.0.0.0/0

Using this config (from the BGP Q&A cisco website) I'm not able to get the default route redistributed into the other EIGRP neighbors. The default route isn't in the routing table nor in the topology table.

Anyone any idea's?

I'm using a couple of 2800 series routers and IOS 12.4.24T.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Redistribute BGP learned default route into EIGRP

Armand,

You need to configure a "default-metric" under the "router eigrp" process for any route to get redistributed into eigrp.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
3 REPLIES
Cisco Employee

Re: Redistribute BGP learned default route into EIGRP

Armand,

You need to configure a "default-metric" under the "router eigrp" process for any route to get redistributed into eigrp.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Redistribute BGP learned default route into EIGRP

Yes, you are correct. Found that out a few minutes ago.

Regards.

New Member

Re: Redistribute BGP learned default route into EIGRP

Is the default in the BGP table ?

ex. sh ip bgp

question :

If there is no default in the BGP table then where and how would the default get into eigrp ?

All your doing in redistribution is taking networks originated in one routing domain and placing them in another routing domain. So if BGP is not originating a default, then no default for eigrp via redist.

HTH

2984
Views
5
Helpful
3
Replies